Operating System & Version
CENTOS 7.9
cPanel & WHM Version
94.0.2

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Dear all,
i try to remove the
PHP warning: PHP Startup: Unable to load dynamic library '/opt/cpanel/ea-php56/root/usr/lib64/php/modules/pdo_mysql.so' - /opt/cpanel/ea-php56/root/usr/lib64/php/modules/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0

without any success.
As i can see EA4 do not have pdo_mysql as an option but pdo_msqlnd instead. I attach some images as for the php configuration.


MariaDB 10.3.28-MariaDB

Thank you
 

Attachments

Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,781
591
273
cPanel Access Level
Root Administrator
Hmmm, do you know what specific action causes that error to happen? Usually that indicates there is a duplicate entry in the PHP configuration, which you could check using the WHM >> MultiPHP INI Editor under the Editor Mode to check that.

If you aren't able to track that down, feel free to submit a ticket to our team and we can check the system directly for you.
 

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Thank you CPRex,
I have one area that run 5.6 version of php so that warning is generated when i am there. Unfortunately i can not find out the specific page. I tried to find the extension=pdo_mysql.so using WHM >> MultiPHP INI Editor with no success. I have also added the

; extension=pdo_mysql.so
at that file without any success.

Is there any alternative solution that i could try before continue with the ticket support?


Thank you again!
 

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Bingo!
What is that zzzzzzz-pecl.ini?
I think that i should disable the extension from that file or?

I open this file and i see these entries:
extension = "pdo.so"
extension = "pdo_sqlite.so"
extension = "pdo_mysql.so"
 

Attachments

Last edited:

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Many thanks @cPRex! Solved.
I just commented
; extension="pdo_mysql.so" line from that zzzzz ini file and i have received no warning so far. I will continue have that under consideration the next couple of days and i will update!

Thank you again!