The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA4 problems changing to mpm_event

Discussion in 'EasyApache' started by jgnowuckenfurries, Jul 16, 2016.

Tags:
  1. jgnowuckenfurries

    jgnowuckenfurries Registered

    Joined:
    Jul 16, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    texas
    cPanel Access Level:
    Root Administrator
    Hi,

    I am getting the following output when trying to change from mpm_forked to mpm_event in both WHM EA4 gui and command line. I have tried to uninstall & reinstall through yum but same issues pop up:


    Code:
    ea_install_profile /etc/cpanel/ea4/p                                                                                                 rofiles/cpanel/worker.json
    The system is resolving package dependencies and conflicts. This may take some t                                                                                                 ime …
    Error: Package: ea-apache24-mod_ssl-2.4.20-3.1.x86_64 (@EA4)
        Requires: ea-apache24 = 2.4.20-3.1
        Removing: ea-apache24-2.4.20-3.1.x86_64 (@EA4)
            ea-apache24 = 2.4.20-3.1
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Removing: ea-apache24-2.4.20-4.4.4.x86_64 (installed)
            ea-apache24 = 2.4.20-4.4.4
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Available: ea-apache24-2.4.16-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.1
        Available: ea-apache24-2.4.16-4.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.2
        Available: ea-apache24-2.4.16-4.3.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.3
        Available: ea-apache24-2.4.16-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-5.1
        Available: ea-apache24-2.4.16-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.1
        Available: ea-apache24-2.4.16-6.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.2
        Available: ea-apache24-2.4.16-8.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-8.1
        Available: ea-apache24-2.4.16-9.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-9.1
        Available: ea-apache24-2.4.17-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-1.1
        Available: ea-apache24-2.4.17-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-2.1
        Available: ea-apache24-2.4.17-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.1
        Available: ea-apache24-2.4.17-3.2.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.2
        Available: ea-apache24-2.4.17-3.3.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.3
        Available: ea-apache24-2.4.18-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-1.1
        Available: ea-apache24-2.4.18-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-2.1
        Available: ea-apache24-2.4.18-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-3.1
        Available: ea-apache24-2.4.18-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-4.1
        Available: ea-apache24-2.4.18-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.1
        Available: ea-apache24-2.4.18-5.2.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.2
        Available: ea-apache24-2.4.18-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-6.1
        Available: ea-apache24-2.4.18-7.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-7.1
        Available: ea-apache24-2.4.20-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-1.1
        Available: ea-apache24-2.4.20-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-2.1
    Error: Package: ea-apache24-mod_proxy_http-2.4.20-3.1.x86_64 (@EA4)
        Requires: ea-apache24 = 2.4.20-3.1
        Removing: ea-apache24-2.4.20-3.1.x86_64 (@EA4)
            ea-apache24 = 2.4.20-3.1
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Removing: ea-apache24-2.4.20-4.4.4.x86_64 (installed)
            ea-apache24 = 2.4.20-4.4.4
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Available: ea-apache24-2.4.16-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.1
        Available: ea-apache24-2.4.16-4.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.2
        Available: ea-apache24-2.4.16-4.3.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.3
        Available: ea-apache24-2.4.16-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-5.1
        Available: ea-apache24-2.4.16-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.1
        Available: ea-apache24-2.4.16-6.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.2
        Available: ea-apache24-2.4.16-8.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-8.1
        Available: ea-apache24-2.4.16-9.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-9.1
        Available: ea-apache24-2.4.17-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-1.1
        Available: ea-apache24-2.4.17-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-2.1
        Available: ea-apache24-2.4.17-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.1
        Available: ea-apache24-2.4.17-3.2.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.2
        Available: ea-apache24-2.4.17-3.3.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.3
        Available: ea-apache24-2.4.18-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-1.1
        Available: ea-apache24-2.4.18-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-2.1
        Available: ea-apache24-2.4.18-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-3.1
        Available: ea-apache24-2.4.18-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-4.1
        Available: ea-apache24-2.4.18-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.1
        Available: ea-apache24-2.4.18-5.2.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.2
        Available: ea-apache24-2.4.18-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-6.1
        Available: ea-apache24-2.4.18-7.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-7.1
        Available: ea-apache24-2.4.20-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-1.1
        Available: ea-apache24-2.4.20-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-2.1
    Error: Package: ea-apache24-mod_proxy-2.4.20-3.1.x86_64 (@EA4)
        Requires: ea-apache24 = 2.4.20-3.1
        Removing: ea-apache24-2.4.20-3.1.x86_64 (@EA4)
            ea-apache24 = 2.4.20-3.1
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Removing: ea-apache24-2.4.20-4.4.4.x86_64 (installed)
            ea-apache24 = 2.4.20-4.4.4
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Available: ea-apache24-2.4.16-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.1
        Available: ea-apache24-2.4.16-4.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.2
        Available: ea-apache24-2.4.16-4.3.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.3
        Available: ea-apache24-2.4.16-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-5.1
        Available: ea-apache24-2.4.16-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.1
        Available: ea-apache24-2.4.16-6.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.2
        Available: ea-apache24-2.4.16-8.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-8.1
        Available: ea-apache24-2.4.16-9.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-9.1
        Available: ea-apache24-2.4.17-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-1.1
        Available: ea-apache24-2.4.17-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-2.1
        Available: ea-apache24-2.4.17-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.1
        Available: ea-apache24-2.4.17-3.2.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.2
        Available: ea-apache24-2.4.17-3.3.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.3
        Available: ea-apache24-2.4.18-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-1.1
        Available: ea-apache24-2.4.18-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-2.1
        Available: ea-apache24-2.4.18-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-3.1
        Available: ea-apache24-2.4.18-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-4.1
        Available: ea-apache24-2.4.18-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.1
        Available: ea-apache24-2.4.18-5.2.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.2
        Available: ea-apache24-2.4.18-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-6.1
        Available: ea-apache24-2.4.18-7.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-7.1
        Available: ea-apache24-2.4.20-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-1.1
        Available: ea-apache24-2.4.20-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-2.1
    Error: Package: ea-apache24-mod_unique_id-2.4.20-3.1.x86_64 (@EA4)
        Requires: ea-apache24 = 2.4.20-3.1
        Removing: ea-apache24-2.4.20-3.1.x86_64 (@EA4)
            ea-apache24 = 2.4.20-3.1
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Removing: ea-apache24-2.4.20-4.4.4.x86_64 (installed)
            ea-apache24 = 2.4.20-4.4.4
        Updated By: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4)
            ea-apache24 = 2.4.20-4.5.1.cpanel
        Available: ea-apache24-2.4.16-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.1
        Available: ea-apache24-2.4.16-4.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.2
        Available: ea-apache24-2.4.16-4.3.x86_64 (EA4)
            ea-apache24 = 2.4.16-4.3
        Available: ea-apache24-2.4.16-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-5.1
        Available: ea-apache24-2.4.16-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.1
        Available: ea-apache24-2.4.16-6.2.x86_64 (EA4)
            ea-apache24 = 2.4.16-6.2
        Available: ea-apache24-2.4.16-8.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-8.1
        Available: ea-apache24-2.4.16-9.1.x86_64 (EA4)
            ea-apache24 = 2.4.16-9.1
        Available: ea-apache24-2.4.17-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-1.1
        Available: ea-apache24-2.4.17-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-2.1
        Available: ea-apache24-2.4.17-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.1
        Available: ea-apache24-2.4.17-3.2.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.2
        Available: ea-apache24-2.4.17-3.3.x86_64 (EA4)
            ea-apache24 = 2.4.17-3.3
        Available: ea-apache24-2.4.18-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-1.1
        Available: ea-apache24-2.4.18-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-2.1
        Available: ea-apache24-2.4.18-3.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-3.1
        Available: ea-apache24-2.4.18-4.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-4.1
        Available: ea-apache24-2.4.18-5.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.1
        Available: ea-apache24-2.4.18-5.2.x86_64 (EA4)
            ea-apache24 = 2.4.18-5.2
        Available: ea-apache24-2.4.18-6.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-6.1
        Available: ea-apache24-2.4.18-7.1.x86_64 (EA4)
            ea-apache24 = 2.4.18-7.1
        Available: ea-apache24-2.4.20-1.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-1.1
        Available: ea-apache24-2.4.20-2.1.x86_64 (EA4)
            ea-apache24 = 2.4.20-2.1
    


    As a side note we are running 10+ Joomla stores and 1 magento store with 5 sub stores from a Centos VPS, I have been attempting to increase page load times, but have been running into many issues with current apache configuration, including the following which is constantly bringing sites down, I'm hoping this will be resolved by rebuilding apache also.

    [cgi:error] [pid 15103] (12)Cannot allocate memory: [client 68.180.228.160:42168] AH01223: couldn't spawn child process: /usr/local/cpanel/cgi-sys/ea-php56
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    Have you setup memory limit in your Apache configuration file. Try to check it with running this command:

    Code:
    grep RLimitMEM /usr/local/apache/conf/httpd.conf
     
  3. jgnowuckenfurries

    jgnowuckenfurries Registered

    Joined:
    Jul 16, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    texas
    cPanel Access Level:
    Root Administrator
    Hi, Thankyou for responding. This directive is not in my configuration file, I believe this is because I have ever executed WHM >> Main >> Service Configuration >> Apache Configuration >> Memory Usage Restrictions. Ok I went in and set RLimits, I set it to the recommended figure of 212 MB, I'll monitor to see what happened, here is the output I got in WHM:

    Updating Apache RLimits …
    Success: Largest Webserver child cgi/ssi/php is now limited to 212 MB.
    Success: No changes were made, so an Apache restart was not performed.

    Strange that it said no changes were made as the initial figure was 0MB.

    update: I had to disable this as all sites returned a 500 error with this applied.

    Any idea about my issues changing from prefork to event?

    Update 2: I increased the figure to 1024MB and I have had no more memory errors appear in apache logs so far
     
    #3 jgnowuckenfurries, Jul 17, 2016
    Last edited: Jul 17, 2016
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    670
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I was able to successfully provision the cPanel Worker MPM profile with EasyApache 4. Could you let us know the version of cPanel installed on your system if the issue persists?

    Thank you.
     
Loading...

Share This Page