Operating System & Version
centos 6 64Bit
cPanel & WHM Version
84

mahdy_sharifi

Well-Known Member
Feb 26, 2012
218
1
68
cPanel Access Level
Root Administrator
Hi :

On centos 6 (cloud linux) when I go EA4 section I see following error :


Error: Package: 1:ea-php52-php-fpm-5.2.17-27.el6.cloudlinux.5.x86_64 (cl-ea4) Requires: ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.5 Installed: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.21.x86_64 (@cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.21 Available: 1:ea-php52-php-common-5.2.17-26.el6.cloudlinux.4.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-26.el6.cloudlinux.4 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.1.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.1 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.5.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.5 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.10.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.10 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.11.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.11 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.19.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.19 Available: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.20.x86_64 (cl-ea4) ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.20 Error: Package: 1:ea-php52-php-fpm-5.2.17-27.el6.cloudlinux.5.x86_64 (cl-ea4) Requires: ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.5 Installed: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.21.x86_64 (@cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.21 Available: 1:ea-php52-php-cli-5.2.17-26.el6.cloudlinux.4.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-26.el6.cloudlinux.4 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.1.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.1 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.5.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.5 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.10.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.10 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.11.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.11 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.19.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.19 Available: 1:ea-php52-php-cli-5.2.17-27.el6.cloudlinux.20.x86_64 (cl-ea4) ea-php52-php-cli(x86-64) = 1:5.2.17-27.el6.cloudlinux.20 The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2020-02-24_17:10:15-1


How can resolve it ?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Removing PHP 5.2 would resolve the error that was being encountered but would not resolve the actual issue. It looks like a package conflict was occurring in respect to the php 5.2 common packages.

Code:
Package: 1:ea-php52-php-fpm-5.2.17-27.el6.cloudlinux.5.x86_64 (cl-ea4) Requires: ea-php52-php-common(x86-64) = 1:5.2.17-27.el6.cloudlinux.5
Code:
Installed: 1:ea-php52-php-common-5.2.17-27.el6.cloudlinux.21.x86_64 (@cl-ea4) ea-php52-php-common(x86-64)