The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

eAccelerator Installed but not working

Discussion in 'General Discussion' started by ks04, Mar 28, 2013.

  1. ks04

    ks04 Member

    Joined:
    Jan 20, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Hi There,

    I recently recompiled my apache using EasyApache and chose to install eaccellerator, however php.info shows it is not enabled
    eAccelerator

    I am using DSO.

    php -v shows eaccelerator is installed:
    Php.ini is setup as follows:

    PHP:
    Directory in which the loadable extensions (modulesreside.
    extension_dir "/usr/local/lib/php/extensions/no-debug-non-zts-20090626"
    extension="eaccelerator.so"
    eaccelerator.cache_dir="/tmp/eaccelerator"
    eaccelerator.check_mtime="1"
    eaccelerator.compress="1"
    eaccelerator.compress_level="9"
    eaccelerator.debug="0"
    eaccelerator.enable="1"
    eaccelerator.filter=""
    eaccelerator.optimizer="1"
    eaccelerator.shm_max="0"
    eaccelerator.shm_only="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_size="16"
    eaccelerator.shm_ttl="0"
    extension="suhosin.so"
    extension "pdo.so"
    extension "pdo_sqlite.so"
    extension "sqlite.so"
    extension "pdo_mysql.so"
    extension "fileinfo.so"
    extension "mailparse.so"
    extension "ffmpeg.so"

    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.3.so"
    I don't see why this not working... thoughts?
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Check the directory where your phpinfo() script is located for a custom php.ini file. If one exists, it will override the system php.ini file if you are using suPHP as your PHP handler, which is the cPanel default.
     
  3. ks04

    ks04 Member

    Joined:
    Jan 20, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Using DSO as the PHP Handler.

    Even tried adding the following to .htaccess with no luck:

    php_flag eaccelerator.enable 1
    php_flag eaccelerator.optimizer 1
     
    #3 ks04, Mar 28, 2013
    Last edited: Mar 28, 2013
Loading...

Share This Page