eAccelerator settings not in tune with phpinfo or eAccelerator control panel

fdnven

Well-Known Member
Feb 14, 2006
120
1
168
Hi,

Currently running 3 servers same setup:
CLOUDLINUX 6.4 x86_64 kvm – delta WHM 11.38.0 (build 18)
eAccelerator 0.9.6.1

Utilizing easyapache I build with eAccelerator etc. After build checking everything working fine. Checking eAccelerator using php info (via cpanel) and eAccelerator control panel. Resutls Caching Enabled True

I then turned off eAccelerator on 2 machines using settings in usr/local/lib/php.ini. Restart apache. confirm via php.info and eAccelerator control panel that indeed eaccelerator.enable="0" was confirmed.

3 weeks later I want to turn back on eAccelerator. I alter eaccelerator.enable="1" restart apache and force CageFS update. Go to confirm and both phpinfo (via cpanel) and eAccelerator control panel are showing Caching Enabled false.

Not sure what is occurring or how to proceed.

Updated info. Found these in /usr/local/cpanel/logs/error_log:
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive directive
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.cache_dir
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.check_mtime
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.compress
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.compress_level
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.debug
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.enable
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.filter
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.optimizer
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.shm_max
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.shm_only
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.shm_prune_period
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.shm_size
[2013-06-23 13:20:58 -0700] info [cpanel] Skipping unknown PHP ini directive eaccelerator.shm_ttl
Thanks
Frank
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Please try uninstalling and reinstalling Eaccelerator via the following commands:

Code:
/scripts/phpextensionmgr uninstall EAccelerator
/scripts/phpextensionmgr install EAccelerator
Thank you.