easy apache 4 compile problems ?

PowerChaos

Member
Feb 5, 2010
6
0
51
hi,
i got this error a lot of times

i use a working profile ( based on full php , changed worker to event )

in the profile i only select PHP 7 so i got a complete full php support and the following errors start showing up

same for mod_realip in the apache config ( nothing is selected there , as soon i select something it trows errors at build page )

this is the errors i keep getting

Code:
Update Error: Error: ea-apache24-mod_mpm_event conflicts with ea-apache24-mod_mpm_prefork-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_mpm_event-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_mpm_event-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_cgi-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_event conflicts with ea-apache24-mod_cgi-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_cgid-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_cgid-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_mpm_prefork-2.4.18-7.1.x86_64
so far i can read it says mpm_prefork ... when it is not installed and mpm_event is used as basic and selection ....

also fastCGI and CGI are not selected ... ( i think its fastcgi that is selected ) so why does it shows me errors of packages that are NOT selected ?

i recently updated to the 56 version , this error also exist in the 54 version

any solution for this ?

Greets From PowerChaos
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Please browse to the "Server Modules" option under "WHM Home » Software » EasyApache 4" and search for the term "cgi". Check to see if you have enabled both "ea-apache24-mod_cgi" and "ea-apache24-mod_cgid".

Thank you.