The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easy Apache boycott

Discussion in 'EasyApache' started by verticalhost, Jul 14, 2004.

  1. verticalhost

    verticalhost Active Member

    Joined:
    Apr 28, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Fort Walton Beach, FL
    What do we have to do to get the problems fixed with Easy Apache. Almost everyone has a problem with compiling the new php versions into their server. Instead of taking minutes, it always takes about 2 hours for my servers to be running properly again and with no benefits of trying to update.

    There is probably a simple fix that we haven't been given yet.

    So as far as that goes, I'm not using easy apache until we get a 99.9% working product.

    Anyone else feel the same way?
     
  2. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    php 4.3.8 works fine via easyapache.

    php 5.0.0 is the one that is causing problems.
     
  3. verticalhost

    verticalhost Active Member

    Joined:
    Apr 28, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Fort Walton Beach, FL
    I beg to differ.

    The only one that was working for me was 4.3.3
    After 2 hours I was able to get 4.3.8 up there.

    I actually had to only install that, and then TRY and install the addon modules for it later.
    Turned out to be a huge pain.
     
  4. eger

    eger Well-Known Member

    Joined:
    Feb 28, 2003
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    16
    the only problem i have had with it is when i tried to compile using the curl options. other than that it works very well for me.
     
  5. liquidcherry

    liquidcherry Well-Known Member

    Joined:
    Jan 20, 2004
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    the ultimate fix!!!!

    hi David,

    i know off a ultimate fix.....

    just shut down your server,leave it alone ,contribute it to all hackers in the world so that they have a toy to play with..... and buy yourself a nice little farm and maintain the herbs or breed cattles,horses :D

    To be honest....just wait a few days to make an update,like i do.....
    Its more than a waste of time to be always "uptodate",the past shows it.....
    Just be patient sometimes,even when something like WHM indicates"evil,evil,evil...UPDATE
    your stuff"

    (besides that i am sure Nick didnt sleep the last 24 hours to fix all problems)

    Of course its bad to be hacked or to be maybe vulnerable(they always find a way to come through ),but there are other ways to secure your stuff before and after an exploit was found

    Other ways? yeah....
    Just go in contact with your Linux Guru who secured your server if you hired one :) :)
    If u dont hired one,pray :)

    Or subscribe to a couple of security related sites so that u can have a good chance to know about a vul. even befor it takes place....

    I really cannot think of a solution what fits for everybody,i am just working in the computer related area since more then 14 years and i know there are millions of configurations out in the field what makes it even more complicated to have a standard solution......and i am not only talking about windows s!@#

    besides that,like mentioned here in the forums, the RHN Servers "been not very cooperative" today for everybody( i am not working for REDHAT :) ) and i guess due to that u had to wait 2 hours...

    but like i said if you want to get rid of dealing with this s!@#,just buy u a nice little farm :)

    No offense was offered here......... :D :eek:

    ##if u are finding some spelling errors,keep it##

    Greetz

    Frank
     
  6. andyorourke

    andyorourke Member

    Joined:
    Dec 17, 2003
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    Problems - What Problems!

    I must be lucky then, Based in the UK I got up at 8 am, saw the big red security warnings and upgraded all 4 of my servers to 4.8 in 45 minutes. I guess the time difference finally worked for me. :)
     
  7. verticalhost

    verticalhost Active Member

    Joined:
    Apr 28, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Fort Walton Beach, FL
    I had no problems with the RHN servers. I always have a problem with what I select in easyapache and then it go haywire.

    You click on everything you want and it gives you only half of what you picked, and then downgrades your php version to 4.3.3 I was running .4 before the update.

    It's just frustration that comes every time I see the "Warning" box.
     
  8. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    I attempted updates to apache/PHP today, only to find it fail. This WAS caused by the up2date servers being unavailable at the time. Once these were back and working, the update went through without any issues whatsoever.
     
  9. liquidcherry

    liquidcherry Well-Known Member

    Joined:
    Jan 20, 2004
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    hi bking

    see......,what i have said earlier?
    BE PATIENT :D

    Frank
     
  10. iko

    iko Well-Known Member
    PartnerNOC

    Joined:
    Jan 29, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    GD cannot be compiled into PHP 4.3.8.

    /home/cpapachebuild/buildapache/php-4.3.8/ext/gd/libgd/gdft.c: In function `gdImageStringFTEx':
    /home/cpapachebuild/buildapache/php-4.3.8/ext/gd/libgd/gdft.c:988: `FT_ENCODING_MS_SYMBOL' undeclared (first use in this function)
    /home/cpapachebuild/buildapache/php-4.3.8/ext/gd/libgd/gdft.c:988: (Each undeclared identifier is reported only once
    /home/cpapachebuild/buildapache/php-4.3.8/ext/gd/libgd/gdft.c:988: for each function it appears in.)
    make: *** [ext/gd/libgd/gdft.lo] Error 1
     
  11. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    [~]# php -i | grep GD &&php -v
    GD Support => enabled
    GD Version => bundled (2.0.23 compatible)
    PHP 4.3.8 (cli) (built: Jul 15 2004 07:13:15)

    ??
     
  12. iko

    iko Well-Known Member
    PartnerNOC

    Joined:
    Jan 29, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    As I told GD was not compiled. I know how to check if it is but unfortunately it is not.
     
Loading...

Share This Page