coderoyal

Well-Known Member
Mar 8, 2005
58
0
156
Hi! I'm having difficulty with the easyapache script! Originally, when I ran it, I got the error as described in detail at http://forums.cpanel.net/showthread.php?p=251639

Before taking these recommended steps, I decided to run upcp first. I've done this, and now when I run easyapache, I get the following error. I am using Red Hat Enterprise AS 4:


********************************
This is buildapache version 10.8.6r4 (ap=1.3.36)
********************************

If you have installed third party modules that buildapache does not install, you will probably need to recompile them after apache is rebuilt. You may experience an unusable apache that produces segmentation faults until the old modules are recompiled or removed.

Select skill level:
If it is possible for you to run phpsuexec, we recommend you do this
by choosing option 2, or using the advanced options.

phpsuexec combinded with webroot protection will prevent people
from reading other users webroots. If you are unable to use
phpsuexec we recommend you enable PHP open_basedir security
inside of Web Host Manager.

The following does not work with phpsuexec: php commands in
.htaccess, php http authentication.

1) Beginner without/phpsuexec + webroot protection support (*** DEFAULT ***)
2) Beginner with/phpsuexec support + web root protection
3) Beginner with/php mcrypt support (if php will not compile, you must choose option 1)
4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)
5) Beginner with/php gd+freetype+mcrypt support (if php will not compile, you must choose option 1)
6) Advanced (Experts Only, At Your Own Risk)
7) Advanced [Load Previous Config] (Experts Only, At Your Own Risk)
8) Failsafe mode (Resets apache config to default, USE ONLY AS A LAST RESORT)
---->5
Apache automatically configured with gd+ttf+mcrypt support!
/etc/rc.d/init.d/httpd start: httpd started
Setting /home permissions to 0711......Done
Setting permissions for.....aria...burgessja...carterj...cj...cweston...daylia...downeast...eagle...ecotat...enterprise...haili...hmotors...holli...krally...liana...owena...photomai...pickren...roseb...sarah...stowit...tiltonm...trinity...violette...wheeler...makenz...taylorj...perkins...carlena6...taylor...morgan...allisyna...wendy...rideout...dcc...alexa...brooke...kristin......Done
20:48:48 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [523321/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
Untarring mcryptDone
configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads)................Done
make -j 1 libmcrypt-2.5.7...........................................Done
make libmcrypt-2.5.7...(install).....Done
./buildscript: line 995: syntax error near unexpected token `('
./buildscript: line 995: `echo -n "Executing /scripts/postbuildapache (if exists)..."'

Waiting for httpd to restart..............finished.

root 17944 0.8 0.6 10828 6260 ? Ss 20:49 0:00 /usr/local/apache/bin/httpd -DSSL

httpd started ok
 

coderoyal

Well-Known Member
Mar 8, 2005
58
0
156
coderoyal said:
Hi! I'm having difficulty with the easyapache script! Originally, when I ran it, I got the error as described in detail at http://forums.cpanel.net/showthread.php?p=251639

Before taking these recommended steps, I decided to run upcp first. I've done this, and now when I run easyapache, I get the following error. I am using Red Hat Enterprise AS 4:


********************************
This is buildapache version 10.8.6r4 (ap=1.3.36)
********************************

If you have installed third party modules that buildapache does not install, you will probably need to recompile them after apache is rebuilt. You may experience an unusable apache that produces segmentation faults until the old modules are recompiled or removed.

Select skill level:
If it is possible for you to run phpsuexec, we recommend you do this
by choosing option 2, or using the advanced options.

phpsuexec combinded with webroot protection will prevent people
from reading other users webroots. If you are unable to use
phpsuexec we recommend you enable PHP open_basedir security
inside of Web Host Manager.

The following does not work with phpsuexec: php commands in
.htaccess, php http authentication.

1) Beginner without/phpsuexec + webroot protection support (*** DEFAULT ***)
2) Beginner with/phpsuexec support + web root protection
3) Beginner with/php mcrypt support (if php will not compile, you must choose option 1)
4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)
5) Beginner with/php gd+freetype+mcrypt support (if php will not compile, you must choose option 1)
6) Advanced (Experts Only, At Your Own Risk)
7) Advanced [Load Previous Config] (Experts Only, At Your Own Risk)
8) Failsafe mode (Resets apache config to default, USE ONLY AS A LAST RESORT)
---->5
Apache automatically configured with gd+ttf+mcrypt support!
/etc/rc.d/init.d/httpd start: httpd started
Setting /home permissions to 0711......Done
Setting permissions for.....aria...burgessja...carterj...cj...cweston...daylia...downeast...eagle...ecotat...enterprise...haili...hmotors...holli...krally...liana...owena...photomai...pickren...roseb...sarah...stowit...tiltonm...trinity...violette...wheeler...makenz...taylorj...perkins...carlena6...taylor...morgan...allisyna...wendy...rideout...dcc...alexa...brooke...kristin......Done
20:48:48 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [523321/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
Untarring mcryptDone
configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads)................Done
make -j 1 libmcrypt-2.5.7...........................................Done
make libmcrypt-2.5.7...(install).....Done
./buildscript: line 995: syntax error near unexpected token `('
./buildscript: line 995: `echo -n "Executing /scripts/postbuildapache (if exists)..."'

Waiting for httpd to restart..............finished.

root 17944 0.8 0.6 10828 6260 ? Ss 20:49 0:00 /usr/local/apache/bin/httpd -DSSL

httpd started ok
This happens if I choose option 1 as well.

I was able to get a working apache by choosing 8, the failsafe option.
 

netlook

Well-Known Member
Mar 25, 2004
335
0
166
This happend to us with this error:

Code:
--03:10:50--  http://layer1.cpanel.net/fp/frontpage-5.2-0.i386.rpm
           => `/var/spool/cpupdates/frontpage-5.2-0.i386.rpm'
Resolving layer1.cpanel.net... 198.66.78.11, 198.66.78.12, 69.72.164.152, ...
Connecting to layer1.cpanel.net|198.66.78.11|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10,682,299 (10M) [audio/x-pn-realaudio-plugin]

100%[==================================================================================>] 10,682,299   192.20K/s    ETA 00:00

03:11:54 (162.69 KB/s) - `/var/spool/cpupdates/frontpage-5.2-0.i386.rpm' saved [10682299/10682299]

error: open of /var/spool/cpupdates/frontpage-2002-SR1.2.i386.rpm failed: No such file or directory
initfpsuexec: using apache 1.x support
./buildscript: line 995: syntax error near unexpected token `('
./buildscript: line 995: `echo -n "Executing /scripts/postbuildapache (if exists)..."'
Waiting for httpd to restart..............finished.

root     30618  8.0  1.0 28960 21788 ?       Ss   03:11   0:00 /usr/local/apache/bin/httpd -DSSL

httpd started ok
Anyone knows how to solve this? We run WHM 10.8.0 cPanel 10.8.1-S31 on CentOS 4.3 i686
 

coderoyal

Well-Known Member
Mar 8, 2005
58
0
156
netlook said:
03:11:54 (162.69 KB/s) - `/var/spool/cpupdates/frontpage-5.2-0.i386.rpm' saved [10682299/10682299]

error: open of /var/spool/cpupdates/frontpage-2002-SR1.2.i386.rpm failed: No such file or directory
initfpsuexec: using apache 1.x support
./buildscript: line 995: syntax error near unexpected token `('
./buildscript: line 995: `echo -n "Executing /scripts/postbuildapache (if exists)..."'
Waiting for httpd to restart..............finished.
Anyone knows how to solve this? We run WHM 10.8.0 cPanel 10.8.1-S31 on CentOS 4.3 i686
Hi! I was having that error as well, but when I updated to cPanel 10.8.2-C110, I saw the frontpage-2002 download during the update process. This at least resolved the Frontpage error.

Have you ran upcp yet?