Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easy Apache Issue - Authentication via Headers isn't working

Discussion in 'EasyApache' started by Taha Haider, Nov 16, 2017.

  1. Taha Haider

    Taha Haider Member

    Joined:
    Dec 24, 2015
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    jeddah
    cPanel Access Level:
    Root Administrator
    we have a client, who is using authentication via HTTP authorization header.

    I have enabled some modules from apache as well but no luck, his code is working fine on centos based virtual hosting but on cPanel it says "Online server missing authorization header"

    Kindly advise Please
     

    Attached Files:

  2. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    27
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Hi @Taha Haider,

    Is CGI in use? CGI specifically strips headers as a security measure:
    Apache Tutorial: Dynamic Content with CGI - Apache HTTP Server Version 2.4
    If so, you'll need to define the header directly in the Apache configuration, via userdata includes, or you'll need to use another handler:
    Modify Apache Virtual Hosts with Include Files - EasyApache 4 - cPanel Documentation
     
    Taha Haider likes this.
Loading...

Share This Page