The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easy Apache never gets through httpd.conf

Discussion in 'EasyApache' started by jandafields, Feb 27, 2008.

  1. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    cPanel 11.18.1-C20683

    Easy Apache always compiles everything fine, but it never likes httpd.conf and "restores working apache"

    Here is the log with the error. Notice the PORT line is blank for some reason. The only thing I can think is that I have the main "Listen" line commented out, and I use custom "Listen" lines in httpd.conf in the form of:

    #Listen 80
    Listen xx.xx.xx.xx:80
    Listen yy.yy.yy.yy:80

    Is that causing CPanel to get confused?

    Here is the error log:


    Code:
    Updating Apache configuration
    Updating Apache configuration
    Updating Apache configuration
    Distilled successfully
    !! Failed to utilized existing Apache configuration file. Resetting Apache configuration to default. !!
    Updating Apache configuration
    Updating Apache configuration
    Updating Apache configuration
    Updating Apache configuration
    Updating Apache configuration
    Distilled successfully
    !! Failed to generate a syntactically correct Apache configuration (/usr/local/apache/conf/httpd.conf.1204168157):
    Configuration problem detected on line 48 of file /usr/local/apache/conf/httpd.conf.1204168157:
            Port takes one argument, A TCP port number
    
            --- /usr/local/apache/conf/httpd.conf.1204168157 ---
            42KeepAliveTimeout 15
            43MinSpareServers 5
            44MaxSpareServers 10
            45StartServers 5
            46MaxClients 150
            47MaxRequestsPerChild 0
            48 ===> Port  <===
            49AccessFileName .htaccess
            50UseCanonicalName On
            51DefaultType text/plain
            52HostnameLookups Off
            53ErrorLog /usr/local/apache/logs/error_log
            54LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
            --- /usr/local/apache/conf/httpd.conf.1204168157 ---
    
     !!
    !! Archiving successful build so it can be restored via --restore-archive once the httpd.conf are resolved !!
    !! Done Archiving successful build !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1204167675' !!
    
    
     
    #1 jandafields, Feb 27, 2008
    Last edited: Feb 27, 2008
  2. viraj

    viraj Well-Known Member

    Joined:
    Sep 28, 2006
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Yes, that is what can be seen through the logs, you can comment one of the entries in the httpd.conf file & check if the Apache updater works out.
     
Loading...

Share This Page