Easy Apache not working - httpd can't restart

fisiculturista

Registered
Jan 16, 2004
3
0
151
I tried to update apache via cpanel easy apache and after that httpd is not working anymore.

I repeated easy apache instalation with many different configurations and the problem is still there.

The error for httpd not working is:

==========
/etc/init.d/httpd restart: httpd not running, trying to start
/etc/init.d/httpd: line 123: /usr/local/apache/bin/httpd: No such file or directory
/etc/init.d/httpd restart: httpd could not be started
==========

I tried to run configtest:

==========
/etc/init.d/httpd: line 175: /usr/local/apache/bin/httpd: No such file or directory
==========

I guess that easy apache is not instaling apache, because it ends without any message of successful instalation. The last line takes a long time and after it SSH turns to command mode display.

==========
!! Pre allocation testing was successfully able to allocate 90MB !!
!!
Ouput from '/bin/sh -c "ulimit -a"':
core file size (blocks, -c) 524288
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) 524288
open files (-n) 4096
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 14335
virtual memory (kbytes, -v) 524288
!!
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1202738727' !!
!!
Ouput from '/bin/sh -c "ulimit -a"':
core file size (blocks, -c) 524288
data seg size (kbytes, -d) unlimited
file size (blocks, -f) unlimited
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) 524288
open files (-n) 4096
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 14335
virtual memory (kbytes, -v) 524288
!!
!! Skipping backup, no working apache found !!
Checking that all tarballs are present and up to date.
Could not determine system package module to use for fedora 1 i686 (wanted to import Cpanel::SysPkgs::)! at /usr/local/cpanel/Cpanel/SysPkgs.pm line 97
Cpanel::SysPkgs::new('Cpanel::SysPkgs') called at /var/cpanel/perl/easy/Cpanel/Easy.pm line 956
Cpanel::Easy::process_tarballs_and_pkgs('Cpanel::Easy::Apache=HASH(0xa465074)') called at /var/cpanel/perl/easy/Cpanel/Easy.pm line 602
Cpanel::Easy::install_profile('Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml','undef') called at /var/cpanel/perl/easy/Cpanel/Easy/Apache.pm line 668
Cpanel::Easy::Apache::install_profile('Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml') called at /var/cpanel/perl/easy/Cpanel/Easy/Utils/BackGround.pm line 37
Cpanel::Easy::Utils::BackGround::__ANON__('Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml','/tmp/.cpanel_easy-.2wzGowXkQnEO0txg') called at /usr/lib/perl5/site_perl/5.8.1/Acme/Spork.pm line 50
Acme::Spork::spork('CODE(0x9b2d654)','Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml','/tmp/.cpanel_easy-.2wzGowXkQnEO0txg') called at /var/cpanel/perl/easy/Cpanel/Easy/Utils/BackGround.pm line 48
Cpanel::Easy::Utils::BackGround::run_install_in_bg('Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml') called at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI.pm line 313
Cpanel::Easy::Apache::UI::CLI::install_profile('Cpanel::Easy::Apache::UI::CLI=HASH(0xa46adbc)','Cpanel::Easy::Apache=HASH(0xa465074)','/var/cpanel/easy/apache/profile/_main.yaml') called at /var/cpanel/perl/easy/Cpanel/Easy.pm line 215
Cpanel::Easy::run('Cpanel::Easy::Apache=HASH(0xa465074)') called at /scripts/easyapache line 29
Checking that all packages are present and up to date.

==========

Any ideas to help?
Thanks.