The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easy::Apache Weirdness

Discussion in 'EasyApache' started by Gene Steinberg, Oct 12, 2007.

  1. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    I'm not a novice, but my knowledge of Apache and PHP are minimal.

    After installing the current RELEASE branch as of this writing, WHM 11.11.0 cPanel 11.15.0-R17659, I attempt to rebuild the Apache installation on my dedicated server, running CentOS Enterprise 4.5.

    The previous Apache installation was 1.3.7. I used the Basic settings for 2.2.6.

    I have installations involving WordPress 2.3 and MyBB 1.2.9, both current versions.

    After the installation, scattered permissions were changed on files, mostly config and setup.

    Specifically:

    IMy WordPress 2.3 blog had some issues, where the full page wouldn't display after the upgrade. I traced it to an unaccountable change in permissions for some plug-ins, config and setup files. I encountered a related issue with a MyBB forum, where a settings file was was changed from 777 to 644, which meant that needed adjustments couldn't be written to the file.

    As I said, I don't speak Apache, and am barely conversant in PHP and less in MySQL.

    Can someone here suggest what caused these changes and if there's something I can do on a global basis to fix things?

    My host, HostICan, says that the Apache configuration looks OK, but I can't expect them to spend hours troubleshooting this.

    Peace,
    Gene Steinberg
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Do you have SuPHP enabled by any chance? If not, it may be a good idea as that will resolve the permissions issues (rather than changing the permissions back to the ever insecure 777).

    You can enable this by going to WHM -> Software -> Apache Update and when you get to Profile :: Apache :: PHP Main :: PHP Specific :: Basic click on "Advanced Configuration" and select SuPHP.

    Note, by enabling this users will typically not be able to read/write each others' scripts, but that's generally considered a good security measure.
     
    #2 cPanelDavidG, Oct 16, 2007
    Last edited: Oct 16, 2007
  3. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    Yes, I have suPHP selected, at least now. I did a rebuild to add the GD/FreeType libraries too.

    It seems to have settled down now, but I still have a couple of WordPress functions that do not work.

    I'm not getting any help for WP people.

    Anyone here who can help?

    One is an SpellCheck error with the TinySpell feature.

    Peace,
    Gene
     
Loading...

Share This Page