The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache 3.9.1 error with modsecurity

Discussion in 'EasyApache' started by kampret, Feb 12, 2012.

  1. kampret

    kampret Member

    Joined:
    Jun 21, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have experienced all of my boxes (Centos 5.7 x86_64) got the same error while on modsec 2.6.3 install with easyapache 3.9.1 :

    Code:
    config.status: executing libtool commands
            -- End step 'configure mod_sec' --
            -- Begin step 'Compile mod_sec' --
    CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /home/cpeasyapache/src/modsecurity-apache_2.6.3/build/missing --run aclocal-1.11 -I build
    configure.ac:20: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
    autoconf/lang.m4:198: AC_LANG_CONFTEST is expanded from...
    autoconf/general.m4:2671: _AC_LINK_IFELSE is expanded from...
    autoconf/general.m4:2681: AC_LINK_IFELSE is expanded from...
    build/libtool.m4:1038: _LT_SYS_MODULE_PATH_AIX is expanded from...
    build/libtool.m4:5245: _LT_LINKER_SHLIBS is expanded from...
    build/libtool.m4:5330: _LT_LANG_C_CONFIG is expanded from...
    build/libtool.m4:250: _LT_SETUP is expanded from...
    build/libtool.m4:99: LT_INIT is expanded from...
    configure.ac:20: the top level
    configure.ac:20: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
    autoconf/lang.m4:198: AC_LANG_CONFTEST is expanded from...
    autoconf/general.m4:2671: _AC_LINK_IFELSE is expanded from...
    autoconf/general.m4:2681: AC_LINK_IFELSE is expanded from...
    build/libtool.m4:5245: _LT_LINKER_SHLIBS is expanded from...
    build/libtool.m4:5330: _LT_LANG_C_CONFIG is expanded from...
    build/libtool.m4:250: _LT_SETUP is expanded from...
    build/libtool.m4:99: LT_INIT is expanded from...
    configure.ac:20: the top level
    configure.ac:594: warning: PKG_PROG_PKG_CONFIG is m4_require'd but not m4_defun'd
    build/find_lua.m4:195: CHECK_LUA is expanded from...
    configure.ac:594: the top level
     cd . && /bin/sh /home/cpeasyapache/src/modsecurity-apache_2.6.3/build/missing --run automake-1.11 --foreign
    Usage: autoconf [-h] [--help] [-m dir] [--macrodir=dir]
           [-l dir] [--localdir=dir] [--version] [template-file]
    automake-1.11: autoconf failed with exit status: 1
    make: *** [Makefile.in] Error 1
    !! 'make' failed with exit code '512' !!
    modsecurity 2.6.3 asked for automake-1.11 and cannot provide by Centos 5.7 since automake-1.11 is currently just for centos 6.
    Centos 5.7 is only have automake 1.9.6 right now.
    Any solution to this automake-1.11 needed by modsecurity 2.3.6 will be greatly appreciate, thank you!
     
  2. kampret

    kampret Member

    Joined:
    Jun 21, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    hello? anyone?
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you considered opening a ticket to cPanel Support for this issue?
     
Loading...

Share This Page