The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easyapache 3 error

Discussion in 'EasyApache' started by kinsky, Oct 4, 2007.

  1. kinsky

    kinsky Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    ====
    Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -lcrypt -lc-client -lexpat -lexpat -lcrypt -lmm -lpq -lpdf -lz -lpng -ljpeg -lmysqlclient -lmhash -lmcrypt -lltdl -lssl -lcrypto -lcrypt -lpam -lfreetype -lX11 -lXpm -lpng -lz -ljpeg -lcurl -lz -lssl -lcrypto -lresolv -lm -ldl -lnsl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lcurl -lidn -lssl -lcrypto -ldl -lz -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lcrypt -lcrypt -o sapi/cli/php
    /opt/php_with_imap_client//lib/libc-client.a(osdep.o)(.text+0x8e3d): In function `ssl_onceonlyinit':
    /home/cpeasyapache/src/imap-2004g/c-client/osdep.c:268: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
    ext/xmlrpc/libxmlrpc/encodings.lo(.text+0x3e): In function `convert':
    /home/cpeasyapache/src/php-4.4.7/ext/xmlrpc/libxmlrpc/encodings.c:63: undefined reference to `libiconv_open'
    ext/xmlrpc/libxmlrpc/encodings.lo(.text+0x92):/home/cpeasyapache/src/php-4.4.7/ext/xmlrpc/libxmlrpc/encodings.c:74: undefined reference to `libiconv'
    ext/xmlrpc/libxmlrpc/encodings.lo(.text+0xdd):/home/cpeasyapache/src/php-4.4.7/ext/xmlrpc/libxmlrpc/encodings.c:94: undefined reference to `libiconv_close'
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] Error 1
    !! 'make' failed with exit code '512' !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/gentomcatlist2' !!
    Compiling report...
    Sending report (212 bytes)...
    !! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '441901' !!
    Report processed.
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1191558003' !!



    I only can re-build with option 1

    help

    regards
     
  2. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    If you add Iconv to PHP4 in the advanced options does it link properly?
     
  3. moslemovic

    moslemovic Member
    PartnerNOC

    Joined:
    May 25, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Yes..i have problem like that...
    and i contact support cpanel and it good now running...
    but php extention and imap still error
     
  4. jsnape

    jsnape Well-Known Member

    Joined:
    Mar 11, 2002
    Messages:
    174
    Likes Received:
    0
    Trophy Points:
    16
    Had the same error on a VPS and increasing the quota on the number of processes from 100 to 300 seems to fix it.
     
Loading...

Share This Page