Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EasyApache 3, Nginx and upgrade to Apache 2.4

Discussion in 'EasyApache' started by zaquria, Jun 23, 2016.

Tags:
  1. zaquria

    zaquria Member

    Joined:
    Dec 15, 2015
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Website Owner
    Hi,

    Need some advice regarding an update and how it will affect us.

    We currently have Apache 2.2 with Ngnix Proxied. with Memcached, OPcache and Mod_Pagespeed and PHP 5.6.22 php-fpm (MPM worker).

    I would like to know would there be any issues or problems with Nginx etc after upgrading to Apache 2.4 and MPM Event via Easyapache 3?

    Thanks,
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,809
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Keep in mind that no native support for Nginx exists with cPanel at this time. Are you using a specific third-party plugin to configure Nginx with cPanel? You can find the active feature request for Nginx at:

    Nginx proxied to Apache (not standalone Nginx)

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. zaquria

    zaquria Member

    Joined:
    Dec 15, 2015
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Website Owner
    The plugin we are using is nginxcp.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,809
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The website associated with that third-party plugin suggests support for Apache 2.4:

    nginx for Apache 2.4 - NginxCP.com

    I've not seen any cases where MPM Event conflicts have been reported, however you can check with their support team to verify if that's the case.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice