Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EasyApache 4 Apr 3 Release

Discussion in 'EasyApache' started by cPanelPhilH, Apr 3, 2019.

  1. cPanelPhilH

    cPanelPhilH Community Manager Staff Member

    Joined:
    Feb 6, 2019
    Messages:
    29
    Likes Received:
    8
    Trophy Points:
    78
    Location:
    Houston
    cPanel Access Level:
    Root Administrator
    We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! This release includes a version update for ea-apache24 to 2.4.39, resolution to an issue with the installation of ea-liblsapi, and a solution for the premature stoppage of /scripts/ea-tomcat85. Please review the release in its entirety, then join us on Slack, Discord, or Reddit to talk about this update and much more



    2019-4-3


    • ea-apache2
      • EA-8307: Update Apache to 2.4.39, drop 2.4.38
    • ea-apache2-config
      • EA-8305: Revert change in EA-8250
    • ea-liblsapi
      • EA-8300: Cannot reinstall ea-liblsapi because of conflicts with liblsapi
    • ea-tomcat85
      • EA-8241: /scripts/ea-tomcat85 prematurely dies if fs.protected_symlinks_create is enabled


    This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.



    SUMMARY
    cPanel, L.L.C. has updated RPMs for EasyApache 4 with Apache version 2.4.39. This release addresses vulnerabilities related to CVE-2019-0197, CVE-2019-0196, CVE-2019-0211, CVE-2019-0217, CVE-2019-0215, and CVE-2019-0220. We strongly encourage all Apache users to upgrade to version 2.4.39.



    AFFECTED VERSIONS



    All versions of Apache through 2.4.38



    SECURITY RATING



    The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:



    CVE-2019-0197 - MEDIUM
    Apache 2.4.39
    Fixed bug in the http2 module related to CVE-2019-0197




    CVE-2019-0196 - MEDIUM
    Apache 2.4.39
    Fixed bug in the http2 module related to CVE-2019-0196




    CVE-2019-0211 - CRITICAL
    Apache 2.4.39
    Fixed bug in Unix MPMs related to CVE-2019-0211




    CVE-2019-0217 - HIGH
    Apache 2.4.39
    Fixed bug in mod_auth_digest related to CVE-2019-0217




    CVE-2019-0215 - HIGH
    Apache 2.4.39
    Fixed bug in the SSL module related to CVE-2019-0215




    CVE-2019-0220 - MEDIUM
    Apache 2.4.39
    Fixed bug related to CVE-2019-0220



    SOLUTION
    cPanel, L.L.C. has released updated RPMs for EasyApache 4 on April 3, 2019, with an updated version of Apache version 2.4.39. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM's Run System Update interface.




    REFERENCES
    NVD - CVE-2019-0197
    NVD - CVE-2019-0196
    NVD - CVE-2019-0211
    NVD - CVE-2019-0217
    NVD - CVE-2019-0215
    NVD - CVE-2019-0220
    http://www.apache.org/dist/httpd/CHANGES_2.4



    For the PGP-signed message, please see EA4-2019-4-3-CVE-signed.



    More Information



    Information about all releases this year can be found in the 2019 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
     
    Infopro likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice