Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EasyApache 4 auto update disable

Discussion in 'EasyApache' started by vacancy, Jan 17, 2017.

Tags:
  1. vacancy

    vacancy Well-Known Member

    Joined:
    Sep 20, 2012
    Messages:
    189
    Likes Received:
    23
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello there

    I use EasyApache 4 on many of my servers, but I do not want the versions of existing installed components to change beyond control. Is there a way to close EasyApache 4 automatic updates?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,853
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can browse to:

    "WHM Home » Server Configuration » Update Preferences"

    Then, update the "Operating System Package Updates" setting to "Never Update".

    This will require you to manually run the "yum update" command to update your system packages.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    linux4me2 likes this.
  3. vacancy

    vacancy Well-Known Member

    Joined:
    Sep 20, 2012
    Messages:
    189
    Likes Received:
    23
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Thank you micheal.

    Can we simply add ea* to the exclude line in /etc/yum.conf to exclude only easyapache 4 yum packages from being automatically updated?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,853
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    That would work as well, however you'd have to remember to manually remove that exclusion anytime you wanted to update the packages or make changes to your build profile.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    vacancy likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice