Status
Not open for further replies.

cPanelTabby

Active Member
Staff member
Dec 13, 2019
31
12
83
cPanel, Houston TX
cPanel Access Level
Root Administrator
EasyApache 4 December 23 Release
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on Discord or Reddit to talk about this update and much more.

2020-12-23
ea-openssl11
  • EA-9478: Update ea-openssl11 to 1.1.1i, drop 1.1.1h (with fix for CVE-2020-1971)
ea-profiles-cpanel
  • ZC-7620: Update Ruby profile for 2.7 on C7 and C8.
libcurl
scl-ruby24-passenger
  • ZC-8096: Use full path in passenger.ruby.
  • ZC-7897: Add version/package specific template file (and support userdata paths like nginx).
  • ZC-7655: Provide/Conflict apache24-passenger.
  • ZC-8143: Compile ruby 2.4 binary to work when called directly.
ea-cpanel-tools
  • ZC-7904: Add EOL recommendation for ruby24 on C7 and later.
ea-nodejs10
  • ZC-8150: Install /etc/cpanel/ea4/passenger.nodejs.
ea-apache2-config
  • EA-9493: Remove need for perl-libwww-perl.
CentOS 8 System OpenSSL
  • ZC-8005: Replace ea-openssl11 with system openssl on C8.
    • apr
    • apr-util
    • ea-apache2
    • ea-freetds
    • ea-libzip
    • ea-nghttp2
    • ea-php74
    • ea-php80
    • scl-libc-client
    • scl-php72
    • scl-php73
Ruby 2.7 in Production
  • EA-9480: Publish ea-ruby27 to production.
    • ea-ruby27
    • ea-ruby27-libuv
    • ea-ruby27-meta
    • ea-ruby27-passenger
    • ea-ruby27-rubygem-mizuho
    • ea-ruby27-rubygem-nokogiri
    • ea-ruby27-rubygem-rack
    • ea-ruby27-rubygem-sqlite3


This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.



SUMMARY
cPanel, L.L.C. has updated RPMs for EasyApache 4 with OpenSSL version 1.1.1i and libcurl version 7.74.0. This release addresses vulnerabilities related to CVE-2020-1971, CVE-2020-8284, CVE-2020-8285, and CVE-2020-8586. We strongly encourage all OpenSSL 1.1 users to update to version 1.1.1i and all libcurl users to update to version 7.74.0.


AFFECTED VERSIONS
All versions of OpenSSL through 1.1.1h.
All versions of libcurl through 7.73.0.


SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:


CVE-2020-1971 - MEDIUM
OpenSSL 1.1.1i
Fixed bug related to CVE-2020-1971.

CVE-2020-8284 - LOW
libcurl 7.74.0
Fixed bug related to CVE-2020-8284.

CVE-2020-8285 - HIGH
libcurl 7.74.0
Fixed bug related to CVE-2020-8285.

CVE-2020-8286 - HIGH
libcurl 7.74.0
Fixed bug related to CVE-2020-8286.


SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on December 23, 2020, with an updated version of libcurl 7.74.0 and OpenSSL 1.1.1i. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM's Run System Update interface.


REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2020-1971
https://nvd.nist.gov/vuln/detail/CVE-2020-8284
https://nvd.nist.gov/vuln/detail/CVE-2020-8285
https://nvd.nist.gov/vuln/detail/CVE-2020-8286
https://curl.se/changes.html
https://www.openssl.org/news/changelog.html#openssl-111



cPanel, L.L.C. has updated RPMs for EasyApache 4 with OpenSSL version 1.1.1i and libcurl version 7.74.0. This release addresses vulnerabilities related to CVE-2020-1971, CVE-2020-8284, CVE-2020-8285, and CVE-2020-8586. We strongly encourage all OpenSSL 1.1 users to update to version 1.1.1i and all libcurl users to update to version 7.74.0.


AFFECTED VERSIONS
All versions of OpenSSL through 1.1.1h.
All versions of libcurl through 7.73.0.


SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:


CVE-2020-1971 - MEDIUM
OpenSSL 1.1.1i
Fixed bug related to CVE-2020-1971.

CVE-2020-8284 - LOW
libcurl 7.74.0
Fixed bug related to CVE-2020-8284.

CVE-2020-8285 - HIGH
libcurl 7.74.0
Fixed bug related to CVE-2020-8285.

CVE-2020-8286 - HIGH
libcurl 7.74.0
Fixed bug related to CVE-2020-8286.


SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on December 23, 2020, with an updated version of libcurl 7.74.0 and OpenSSL 1.1.1i. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM's Run System Update interface.


REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2020-1971
https://nvd.nist.gov/vuln/detail/CVE-2020-8284
https://nvd.nist.gov/vuln/detail/CVE-2020-8285
https://nvd.nist.gov/vuln/detail/CVE-2020-8286
https://curl.se/changes.html
https://www.openssl.org/news/changelog.html#openssl-111

Click for the PGP Signed message.

More Information

Information about all releases this year can be found in the 2020 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
Status
Not open for further replies.