EasyApache 4 Frozen on Loading profiles

AllOnMyOhm

Registered
Jul 6, 2020
3
0
1
UK
cPanel Access Level
Root Administrator
Hello Lords n Ladies,

I seem to be having some issues with EasyApache 4 (I'm using CentOS 7.8) after loading a few PHP extensions on a custom profile.I can no longer load any of the profiles.
I am stuck on an infinite loop of "Loading profiles …" & when trying to access PHP versions through MultiPHP manager " Gathering PHP-FPM packages information …" again in an infinite loop. Not quite sure how I've screwed up this time.

._. All I wanted to do was enable Zip Archives. Is there a way to disable what was enabled without going through there? Or is there a way to remove that profile and the associated enabled extensions?

Apologies I am somewhat of a newbie to all of this, it's all very fun and Cpanel seems to have a great community behind it so I thought I'd reach out.

All I can see in the error log is:
AH01630: client denied by server configuration: /home/X/public_html/php.ini

Update after leaving it load for an hour or so this appeared:
The YUM cache is incomplete. The system is updating the cache to repair the issue. This operation can take a few minutes to complete (it is very network and disk i/o intensive). EasyApache 4 will be available as soon as possible …
The result of which after several hours was:
YUM encountered errors outside of EasyApache 4. Log into the system via SSH to resolve them, or you can click the ‘Refresh’ button to rebuild the system‘s YUM cache.

Terminal/SSH isn't throwing anything back at me I've tried the following as root:

yum clean all

yum update


Unfortunately it seems now that no yum command works in the terminal

It would seem the proverbial ship is sinking as I cannot access plugins anymore either:

(XID gvtyx9) The system aborted the subprocess “/bin/rpm” (process ID “23078”) because it reached the timeout of 15 seconds. at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 546.
Cpanel::SafeRun::Object::die_if_error(Cpanel::SafeRun::Object=HASH(0x2a1a970)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 538
Cpanel::SafeRun::Object::new_or_die("Cpanel::SafeRun::Object", "program", "/bin/rpm", "args", ARRAY(0x179bed0), "timeout", 15, "read_timeout", ...) called at /usr/local/cpanel/Cpanel/GenSysInfo.pm line 264
Cpanel::GenSysInfo::_run_with_timeout("/bin/rpm", "--query", "--nosignature", "--nodigest", "--queryformat", "%{NAME} %{VERSION}\\n", "--file", "/etc/redhat-release") called at /usr/local/cpanel/Cpanel/GenSysInfo.pm line 204
Cpanel::GenSysInfo::_get_rpm_distro_version_arch() called at /usr/local/cpanel/Cpanel/GenSysInfo.pm line 124
Cpanel::GenSysInfo::_get_new_conf(HASH(0x2148000)) called at /usr/local/cpanel/Cpanel/GenSysInfo.pm line 51
Cpanel::GenSysInfo::run() called at /usr/local/cpanel/Cpanel/GenSysInfo.pm line 71
Cpanel::GenSysInfo::get_rpm_distro_version() called at /usr/local/cpanel/Cpanel/Plugins.pm line 181
Cpanel::Plugins::_do_url_variable_substitution("http://httpupdate.cpanel.net/cpanel-plugins-c\$cp_centos_major"...) called at /usr/local/cpanel/Cpanel/Plugins.pm line 158
Cpanel::Plugins::get_baseurls() called at /usr/local/cpanel/Whostmgr/Addons/RPM/Cache.pm line 170
Whostmgr::Addons::RPM::Cache::_yum_modules() called at /usr/local/cpanel/Whostmgr/Addons/RPM/Cache.pm line 102
Whostmgr::Addons::RPM::Cache::_LOAD_FRESH("Whostmgr::Addons::RPM::Cache") called at /usr/local/cpanel/Cpanel/CacheFile.pm line 234
Cpanel::CacheFile::load("Whostmgr::Addons::RPM::Cache") called at /usr/local/cpanel/Whostmgr/Addons/RPM/Cache.pm line 91
Whostmgr::Addons::RPM::Cache::load("Whostmgr::Addons::RPM::Cache") called at /usr/local/cpanel/Whostmgr/Addons/RPM.pm line 62
Whostmgr::Addons::RPM::get_modules() called at whostmgr/bin/whostmgr2.pl line 2531
main::manage_plugins("manage_plugins") called at /usr/local/cpanel/Whostmgr/Dispatch.pm line 274
Whostmgr::Dispatch::_do_call("manage_plugins", HASH(0x2145770), HASH(0x214a890)) called at /usr/local/cpanel/Whostmgr/Dispatch.pm line 172
Whostmgr::Dispatch::dispatch("manage_plugins", 1, ARRAY(0x2147af8), HASH(0x214a890)) called at whostmgr/bin/whostmgr2.pl line 773
 
Last edited:

AllOnMyOhm

Registered
Jul 6, 2020
3
0
1
UK
cPanel Access Level
Root Administrator
Nothing happens when I rebuild the database, but I just tried this...



# tail /var/log/yum.log

/var/log/yum.log

Jul 06 10:55:35 Installed: tokyocabinet-1.4.48-3.el7.x86_64
Jul 06 10:55:35 Installed: ea-openssl11-devel-1.1.1g-1.1.2.cpanel.x86_64
Jul 06 10:55:37 Installed: 12:aspell-0.60.6.1-9.el7.x86_64
Jul 06 10:55:37 Installed: postgresql-libs-9.2.24-4.el7_8.x86_64
Jul 06 10:55:37 Installed: ea-php71-libc-client-devel-2007f-18.18.3.cpanel.x86_64
Jul 06 10:55:38 Installed: 1:enchant-1.6.0-8.el7.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-enchant-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php71-libc-client-static-2007f-18.18.3.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-pgsql-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-pspell-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-dba-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-intl-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-soap-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-zip-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-gmp-7.3.19-1.1.2.cpanel.x86_64
Jul 06 10:55:38 Installed: ea-php73-php-odbc-7.3.19-1.1.2.cpanel.x86_64
 
Last edited:

AllOnMyOhm

Registered
Jul 6, 2020
3
0
1
UK
cPanel Access Level
Root Administrator
Is there a way to remove these new additions through the terminal due to not being able to do it through cpanel itself?

Perhaps their is a conflict or some kind of corruption after installing this?


Update

Running dcrpm provides this error message:


2020-07-08 14:21:51,147 ERROR [rpmutil.kill_spinning_rpm_query_processes]: Found stale rpm process: (7042) /usr/bin/rpm -q --nodigest --nosignature --queryforma
2020-07-08 14:21:51,505 ERROR [dcrpm.run]: DB needs recovery
2020-07-08 14:21:55,982 WARNING [rpmutil.verify_tables]: Skipping table 'Obsolet ename', blacklisted


yum commands dont return anything and rebuilding the RPM database doesn't seem to change anything.
 
Last edited:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
I would suggest opening a ticket with us over suggesting to remove a package at this moment. If you do open a ticket please update this thread with the ticket ID so we can follow up here.