Status
Not open for further replies.

cPanelTabby

Well-Known Member
Staff member
Dec 13, 2019
72
24
83
cPanel, Houston TX
cPanel Access Level
Root Administrator
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.

2021-7-7
ea-nginx
  • EA-9909: Add hard coded fallback values for keys in settings.json.
  • ZC-9005: Do not hide Upgrade header when proxying websockets under main service subdomains.
  • ZC-9018: Rebuild all users, reporting any issues at the end.
  • ZC-9020: Add cache-related methods to adminbin.
  • EA-9874: Cache 301 redirects.
  • EA-9814: Set client_max_body_size to 128m.
  • ZC-9009: Do not die when a domain’s PHP config is missing.
  • ZC-8589: Improve proxy/SSL configuration.
ea-apache2-config
  • ZC-8936: Address C8 issue with 001-ensure-nobody hook.
ea-modsec2-rules-owasp-crs
  • EA-9921: Update ea-modsec2-rules-owasp-crs to 3.3.2, drop 3.3.0. Version update includes CVE-2021-35368 (previously patched).
ea-php74
ea-php74-meta
ea-php80
ea-php80-meta
ea-ruby27
  • EA-9864: Update ea-ruby27 to 2.7.3, drop 2.7.2.
  • ZC-8967: Update ea-ruby27 to 2.7.3, drop 2.7.2.
  • ZC-8891: Update ea-ruby27 to 2.7.3, drop 2.7.2.
ea-ruby27-meta
  • EA-9864: Update ea-ruby27 to 2.7.3, drop 2.7.2.
  • ZC-8967: Update ea-ruby27 to 2.7.3, drop 2.7.2.
  • ZC-8891: Update ea-ruby27 to 2.7.3, drop 2.7.2.
ea-ruby27-rubygem-nokogiri
  • EA-9904: Update ea-ruby27-rubygem-nokogiri to 1.11.7, drop 1.11.6.
ea-ruby27-passenger
  • EA-9860: Update ea-ruby27-passenger from v6.0.9, drop 6.0.8.
mod_bw
  • ZC-8700: Rename the tarball, Fix for C8.
scl-php73
scl-php73-meta
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated RPMs for EasyApache 4 with PHP versions 7.3.29, 7.4.21, and 8.0.8. This release addresses vulnerabilities related to CVE-2021-21704 and CVE-2021-21705. We strongly encourage all PHP 7.3 users to upgrade to version 7.3.29, all PHP 7.4 users to upgrade to version 7.4.21, and all PHP 8.0 users to upgrade to version 8.0.8.

AFFECTED VERSIONS
All versions of PHP 7.3 through 7.3.28.
All versions of PHP 7.4 through 7.4.20.
All versions of PHP 8.0 through 8.0.8.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2021-21704 - MEDIUM
PHP 7.3.29
Fixed vulnerability related to CVE-2021-21704.

PHP 7.4.21
Fixed vulnerability related to CVE-2021-21704.

PHP 8.0.8
Fixed vulnerability related to CVE-2021-21704.

CVE-2021-21705 - MEDIUM
PHP 7.3.29
Fixed vulnerability related to CVE-2021-21705.

PHP 7.4.21
Fixed vulnerability related to CVE-2021-21705.

PHP 8.0.8
Fixed vulnerability related to CVE-2021-21705.

SOLUTION
cPanel, L.L.C. has released updated RPMs for EasyApache 4 on July 7, 2021, with PHP versions 7.3.29, 7.4.21, and 8.0.8. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM's Run System Update interface.

REFERENCES
https://www.php.net/ChangeLog-7.php#7.4.21
https://www.php.net/ChangeLog-7.php#7.3.29
https://www.php.net/ChangeLog-8.php#8.0.8
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21704
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21705

EA4-2021-7-7-CVE.signed

More Information

Information about all releases this year can be found in the 2021 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
  • Like
Reactions: cPRex
Status
Not open for further replies.