Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EasyApache 4 May 8 Release

Discussion in 'EasyApache' started by cPanelPhilH, May 8, 2019.

  1. cPanelPhilH

    cPanelPhilH Community Manager Staff Member

    Joined:
    Feb 6, 2019
    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    78
    Location:
    Houston
    cPanel Access Level:
    Root Administrator
    We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! This release contains a debuginfo package for ea-liblsapi, a fix for an Apache issue with symlink protection, and a number of PHP updates. Take a look at some highlights below, and then join us on Slack, Discord, or Reddit to talk about this update and much more.

    • ea-liblsapi
      • EA-8330 - Build debuginfo package for ea-liblsapi

    • ea-apache2
      • CPANEL-27056 - apache is serving up root owned files when symlink protection is enabled

    • scl-php71
    • scl-php71-meta
      • EA-8431 - Update PHP71 from 7.1.28 to 7.1.29

    • scl-php72
    • scl-php72-meta
      • EA-8427 - Update PHP72 from v7.2.17 to v7.2.18

    • scl-php73
    • scl-php73-meta
      • EA-8428 - Update PHP73 from v7.3.4 to v7.3.5

    This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.


    SUMMARY
    cPanel, L.L.C. has updated RPMs for EasyApache 4 with PHP versions 7.1.29, 7.2.18, and 7.3.5. This release addresses vulnerabilities related to CVE-2019-11036 and another other vulnerability which has not yet been assigned a number. We strongly encourage all PHP 7.1 users to upgrade to version 7.1.29, all PHP 7.2 users to upgrade to version 7.2.18, all PHP 7.3 users to upgrade to version 7.3.5.


    AFFECTED VERSIONS
    All versions of PHP 7.1 through 7.1.28
    All versions of PHP 7.2 through 7.2.17
    All versions of PHP 7.3 through 7.3.4


    SECURITY RATING
    The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

    CVE-2019-11036 - CRITICAL

    PHP 7.1.29
    Fixed bug in Exif module related to CVE-2019-11036

    PHP 7.2.18
    Fixed bug in Exif module related to CVE-2019-11036

    PHP 7.3.5
    Fixed bug in Exif module related to CVE-2019-11036


    There is another security vulnerability included in this release which has not yet been assigned a number.

    SOLUTION
    cPanel, L.L.C. has released updated RPMs for EasyApache 4 on March 13, 2019, with updated versions of PHP versions 7.1.29, 7.2.18, and 7.3.5. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM's Run System Update interface.


    REFERENCES
    NVD - CVE-2019-11036
    PHP: PHP 7 ChangeLog



    More Information

    Information about all releases this year can be found in the 2019 EasyApache 4 Changelog and the EasyApache 4 Release Notes. To ensure that you receive up-to-date product news from cPanel, we encourage you to subscribe to the Product and Security updates mailing list on our website. You can also sign up for our EasyApache Development and EasyApache Production lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice