SOLVED EasyApache 4 migration - Experimental Repo Required

mojiba2

Member
Nov 12, 2014
6
0
51
cPanel Access Level
Website Owner
I'm trying to migrate to easyapache 4, without success.

Following the EasyApache 4 Migration Tool link I get this screen:
Code:
Pre-flight check result.
cPanel Migration Blocker (Cpanel)
cPanel evaluates known issues such as network connectivity.
Warning: EasyApache 4 does not support the requested Apache version, v2.2. The system will upgrade you to v2.4.
Warning: “Cpanel::Easy::PHP5::MailHeaders” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::PHP5::MagicQuotes” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::ModCloudflare” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::EAccelerator” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::Apache::Fileprotect” ignored since it does not have an RPM.
Warning: “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM.
Warning: ea-apache24-mod_mpm_event found, removing conflicting php DSO package
Warning: Current profile has the following MPMs: ea-apache24-mod_mpm_event
Warning: Adding the missing package, ea-apache24-mod_suexec, to the EasyApache 4 profile.
This action will disable EasyApache 3 and enable EasyApache 4 on this server.
After pushing the "Migrate" button:
Code:
Confirm Your Action
Run EasyApache 4 Migration?
Confirm that you wish for the system to disable EasyApache 3 and enable EasyApache 4.
Clicking "Yes, run EasyApache 4 Migration." I got:
Code:
EasyApache 4 Migration has run successfully.
CHILD_PID: 18861
checkyum version 22.3
[2018-11-13 00:09:34 -0200] info [migrate_ea3_to_ea4] Setting the system default PHP version to v5.6 using the Apache 'fcgi' handler.
[2018-11-13 00:09:34 -0200] info [migrate_ea3_to_ea4]
EasyApache 4 Installing preliminary tools.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] The ea3 Apache version is 2_4; the profile being converted is 2_2
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4]
EasyApache 4 converted your EasyApache 3 profile, with warnings.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] Adding the missing package, ea-apache24-mod_suexec, to the EasyApache 4 profile.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] Current profile has the following MPMs: ea-apache24-mod_mpm_event
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] ea-apache24-mod_mpm_event found, removing conflicting php DSO package
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] “Cpanel::Easy::EAccelerator” ignored since it does not have an RPM.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] “Cpanel::Easy::ModCloudflare” ignored since it does not have an RPM.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] EasyApache 4 does not support the requested  Apache version, v2.2. The system will upgrade you to v2.4.
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] Something is wrong
[2018-11-13 00:09:35 -0200] info [migrate_ea3_to_ea4] EasyApache 3 profile was converted to “/etc/cpanel/ea4/profiles/custom/ea3_state_at_migration-1542074975.json”.
You must have the EA4 Experimental YUM repository installed and enabled for: ea-apache24-mod_fcgid
You can find out about that at The Experimental Repository - EasyApache 4 - cPanel Documentation
A record of this process may be found at : /var/cpanel/updatelogs/ea4_migration.1542074973.log
EasyApache 4 Migration has run successfully.
Then, when I press "Done" the process starts again. I did it three times, what I'm missing here?

Thanks.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello @mojiba2,

You'll need to install the EasyApache 4 experimental repo prior to upgrading to EA4 if you'd like to continue using mod_fcgid on the system. You can install the experiential repo using the following command:

Code:
yum install ea4-experimental
Then, attempt to convert to EA4 again and let us know the result.

Thank you.
 

mojiba2

Member
Nov 12, 2014
6
0
51
cPanel Access Level
Website Owner
Hi Michael,

I really don't need mod_fcgid, I'm using it as an old solution to get better performance on a vbulletin 4 installation.

Do you advise to install the experimental repo, or change the EasyApache 3 profile to a non fcgid option and then upgrade to EasyApache 4?

If so, do you know which profile would be best for vbulletin 4?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Do you advise to install the experimental repo, or change the EasyApache 3 profile to a non fcgid option and then upgrade to EasyApache 4?
Hello @mojiba2,

I recommend installing the EA4 experiential repo and proceeding the EA4 conversion. Once you've upgraded to EA4, you can then browse to WHM >> EasyApache 4 and WHM >> MultiPHP Manager to configure the PHP handlers you prefer to use (if FCGId is no longer your preference).

I don't have a specific profile recommendation for Vbulletin, but you check out our Optimization category to see a list of threads where optimization/resource usage is discussed:

Workarounds and Optimization

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hi @mojiba2,

I'm glad to see it went well. Thanks for sharing the outcome!