cPanelTabby

Well-Known Member
Staff member
Dec 13, 2019
94
29
93
cPanel, Houston TX
cPanel Access Level
Root Administrator
EasyApache 4 November 23 Release
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.

2021-11-23
ea-nginx
  • EA-10221: Always configure domains to use CloudFlare.
scl-php73
  • EA-10281: Update scl-php73 to 7.3.33, drop 7.3.32 (with fix for CVE-2021-21707).
scl-php73-meta
  • EA-10281: Update scl-php73 to 7.3.33, drop 7.3.32 (with fix for CVE-2021-21707).
ea-php74
  • EA-10279: Update ea-php74 to 7.4.26, drop 7.4.25 (with fix for CVE-2021-21707).
ea-php74-meta
  • EA-10279: Update ea-php74 to 7.4.26, drop 7.4.25 (with fix for CVE-2021-21707).
ea-php80
  • EA-10284: Update ea-php80 to 8.0.13, drop 8.0.12 (with fix for CVE-2021-21707).
ea-php80-meta
  • EA-10284: Update ea-php80 to 8.0.13, drop 8.0.12 (with fix for CVE-2021-21707).
mod_security2
  • EA-10229: Add patch to allow run-regression-tests.pl to function with EA4.
ea-tomcat85
  • EA-10280: Update ea-tomcat85 to 8.5.73, drop 8.5.72.
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated packages for EasyApache 4 with PHP versions 8.0.13, 7.4.26, and 7.3.33. This release addresses vulnerabilities related to CVE-2021-21707. We strongly encourage all PHP 8.0 users to upgrade to version 8.0.13, all PHP 7.4 users to upgrade to version 7.4.26, and all PHP 7.3 users to upgrade to version 7.3.33.

AFFECTED VERSIONS
All versions of PHP 8.0 through 8.0.12.
All versions of PHP 7.4 through 7.4.25.
All versions of PHP 7.3 through 7.3.32.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2021-21707 - MEDIUM
PHP 8.0.12
Fixed vulnerability in XML related to CVE-2021-21707.

PHP 7.4.25
Fixed vulnerability in XML related to CVE-2021-21707.

PHP 7.3.32
Fixed vulnerability in XML related to CVE-2021-21707.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on November 23, 2021, with PHP versions 8.0.13, 7.4.26, and 7.3.33. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM's Run System Update interface.

REFERENCES
https://www.php.net/ChangeLog-8.php#8.0.13
https://www.php.net/ChangeLog-7.php#7.4.26
https://www.php.net/ChangeLog-7.php#7.3.36
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21707

For the signed CVE document click here.

More Information

Information about all releases this year can be found in the 2021 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.