Status
Not open for further replies.

cPanelTabby

Well-Known Member
Staff member
Dec 13, 2019
94
29
93
cPanel, Houston TX
cPanel Access Level
Root Administrator
EasyApache 4 October 27 Release
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.

2021-10-27
ea-php80
  • EA-10044: Patch PHP-FPM/OpCache for kill_all_lockers bug (74709)
  • EA-10225: Update ea-php80 to 8.0.12, drop 8.0.11 (with fix for CVE-2021-21703).
ea-php80-meta
  • EA-10044: Patch PHP-FPM/OpCache for kill_all_lockers bug (74709)
  • EA-10225: Update ea-php80 to 8.0.12, drop 8.0.11 (with fix for CVE-2021-21703).
ea-php74
  • EA-10228: Update ea-php74 to 7.4.25, drop 7.4.24 (with fix for CVE-2021-21703).
ea-php74-meta
  • EA-10228: Update ea-php74 to 7.4.25, drop 7.4.24 (with fix for CVE-2021-21703).
scl-php73
  • EA-10237: Update scl-php73 to 7.3.32, drop 7.3.31 (with fix for CVE-2021-21703).
scl-php73-meta
  • EA-10237: Update scl-php73 to 7.3.32, drop 7.3.31 (with fix for CVE-2021-21703).
ea-nghttp2
  • EA-10224: Update ea-nghttp2 to 1.46.0, drop 1.45.1.
ea-modsec2-rules-owasp-crs
  • ZC-9412: Add is_pkg for 102 and beyond.
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated packages for EasyApache 4 with PHP versions 8.0.12, 7.4.25, and 7.3.32. This release addresses vulnerabilities related to CVE-2021-21703. We strongly encourage all PHP 8.0 users to upgrade to version 8.0.12, all PHP 7.4 users to upgrade to version 7.4.25, and all PHP 7.3 users to upgrade to version 7.3.32.

AFFECTED VERSIONS
All versions of PHP 8.0 through 8.0.11.
All versions of PHP 7.4 through 7.4.24.
All versions of PHP 7.3 through 7.3.31.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2021-21703 - HIGH
PHP 8.0.12
Fixed vulnerability in PHP-FPM related to CVE-2021-21703.

PHP 7.4.25
Fixed vulnerability in PHP-FPM related to CVE-2021-21703.

PHP 7.3.32
Fixed vulnerability in PHP-FPM related to CVE-2021-21703.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on October 27, 2021, with PHP versions 8.0.12, 7.4.25, and 7.3.32. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM's Run System Update interface.

REFERENCES
https://www.php.net/ChangeLog-8.php#8.0.12
https://www.php.net/ChangeLog-7.php#7.4.25
https://www.php.net/ChangeLog-7.php#7.3.32
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21703

Download the signed PGP of this CVE message.

More Information

Information about all releases this year can be found in the 2021 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
Status
Not open for further replies.