Status
Not open for further replies.

cPanelTabby

Well-Known Member
Staff member
Dec 13, 2019
87
28
93
cPanel, Houston TX
cPanel Access Level
Root Administrator
EasyApache 4 September 22 Release
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.

2021-9-22
ea-nginx
  • EA-10108: Update ea-nginx to 1.21.3, drop 1.21.2.
  • ZC-9261: Allow include to prefix proxy_cache_key based on any criteria.
  • ZC-9260: Move standalone includes to separate folder and bring in server includes on reverse proxy and standalone.
libcurl
ea-tomcat85
  • EA-10109: Update ea-tomcat85 to 8.5.71, drop 8.5.70.
ea-apache2
mod_security2
  • ZC-9217: Fix the RPM path for modsec_audit.
  • ZC-8704: Build for Ubuntu, and minor changes for CentOS.
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated packages for EasyApache 4 with Apache 2.4.49 and libcurl 7.79.0. This release addresses vulnerabilities related to CVE-2021-22945, CVE-2021-22946, CVE-2021-22947, CVE-2021-40438, CVE-2021-39275, CVE-2021-36160, CVE-2021-34798, and CVE-2021-33193. We strongly encourage all Apache users to upgrade to version 2.4.49 and all libcurl users to upgrade to version 7.79.0.

AFFECTED VERSIONS
All versions of Apache through 2.4.48.
All versions of libcurl through 7.78.0.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2021-40438 - MEDIUM
Apache 2.4.49
Fixed vulnerability related to CVE-2021-40438.

CVE-2021-39275 - MEDIUM
Apache 2.4.49
Fixed vulnerability related to CVE-2021-39275.

CVE-2021-36160 - MEDIUM
Apache 2.4.49
Fixed vulnerability related to CVE-2021-36160.

CVE-2021-34798 - MEDIUM
Apache 2.4.49
Fixed vulnerability related to CVE-2021-34798.

CVE-2021-33193 - HIGH
Apache 2.4.49
Fixed vulnerability related to CVE-2021-33193.

CVE-2021-22945 - MEDIUM
libcurl 7.79.0
Fixed vulnerability related to CVE-2021-22945.

CVE-2021-22946 - MEDIUM
libcurl 7.79.0
Fixed vulnerability related to CVE-2021-22946.

CVE-2021-22947 - MEDIUM
libcurl 7.79.0
Fixed vulnerability related to CVE-2021-22947.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on September 22, 2021, with Apache version 2.4.49 and libcurl 7.79.0. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM's Run System Update interface.

REFERENCES
https://curl.se/changes.html
https://downloads.apache.org/httpd/CHANGES_2.4.49
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22945
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22946
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22947
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-40438
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-39275
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36160
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-34798
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-33193

Link to the signed PGP version is below:

https://news.cpanel.com/wp-content/uploads/2021/09/EA4-2021-9-22-CVE.signed.txt

More Information

Information about all releases this year can be found in the 2021 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
Status
Not open for further replies.