Status
Not open for further replies.

cPanelTabby

Well-Known Member
Staff member
Dec 13, 2019
87
28
93
cPanel, Houston TX
cPanel Access Level
Root Administrator
EasyApache 4 September 29 Release
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.

2021-9-29
ea-php74
  • EA-10136: Update ea-php74 to 7.4.24, drop 7.4.23 (with fix for CVE-2021-21706).
ea-php74-meta
  • EA-10136: Update ea-php74 to 7.4.24, drop 7.4.23 (with fix for CVE-2021-21706).
ea-php80
  • EA-10130: Update ea-php80 to 8.0.11, drop 8.0.10 (with fix for CVE-2021-21706).
ea-php80-meta
  • EA-10130: Update ea-php80 to 8.0.11, drop 8.0.10 (with fix for CVE-2021-21706).
scl-php73
  • EA-10132: Update scl-php73 to 7.3.31, drop 7.3.30 (with fix for CVE-2021-21706).
scl-php73-meta
  • EA-10132: Update scl-php73 to 7.3.31, drop 7.3.30 (with fix for CVE-2021-21706).
ea-nginx
  • ZC-9317: Stop using the deprecated (and unused) module.
ea-apache2-config
  • ZC-9253: Install nobody hook via ea-cpanel-tools so it’s available for pre-txn profile install.
ea-cpanel-tools
  • ZC-9253: Install nobody hook via ea-cpanel-tools so it’s available for pre-txn profile install.
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated packages for EasyApache 4 with PHP versions 7.3.31, 7.4.24, and 8.0.11.. This release addresses vulnerabilities related to CVE-2021-21706. We strongly encourage all PHP 7.3 users to upgrade to version 7.3.31, all PHP 7.4 users to upgrade to version 7.4.24, and all PHP 8.0 users to upgrade to version 8.0.11.

AFFECTED VERSIONS
All versions of PHP 7.3 through 7.3.30.
All versions of PHP 7.4 through 7.4.23.
All versions of PHP 8.0 through 8.0.10.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2021-21706 - MEDIUM
PHP 7.3.31
Fixed vulnerability related to CVE-2021-21706.

PHP 7.4.24
Fixed vulnerability related to CVE-2021-21706.

PHP 8.0.11
Fixed vulnerability related to CVE-2021-21706.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on September 29, 2021, with PHP versions 7.3.31, 7.4.24, and 8.0.11. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM's Run System Update interface.

REFERENCES
https://www.php.net/ChangeLog-7.php
https://www.php.net/ChangeLog-8.php
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21706

For the PGP-Signed version of this update, please click here.

More Information

Information about all releases this year can be found in the 2021 EasyApache 4 Changelog and the EasyApache 4 Release Notes. You can also sign up for our EasyApache Development and EasyApache Production mailing lists to see when updates are pushed for our RPMs, letting you know ahead of time what will be updated in each EasyApache release.
 
Status
Not open for further replies.