Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache 4 Update - December 13, 2016

Discussion in 'EasyApache' started by cPStacy, Dec 14, 2016.

  1. cPStacy

    cPStacy Technical Writer
    Staff Member

    Joined:
    Jul 23, 2014
    Messages:
    90
    Likes Received:
    4
    Trophy Points:
    83
    cPanel Access Level:
    Root Administrator
    The EasyApache team published updates to the EasyApache 4 repository. EasyApache 4 does not use versioning and organizes changes by date only.

    2016-12-13
    • ea-apache2 -
      • 2.4.23-6 - EA-5712: Patch apachectl to set PORT based on cpanel configuration
      • 2.4.23-7 - EA-5662: Update apachectl with ulimit calls modifying the open file descriptor limit so that Apache will start up
    • ea-apache2-config
      • 1.0-74 - EA-5658: Do hard restart of apache when mod_fcgid is involved in a transaction
      • 1.0-75 - EA-5533: Avoid crossing filesystems in location of pid file.
      • 1.0-76 - EA-5712: Remove 510-update-apachectl universal hook
      • 1.0-77 - EA-5724: Allow splitlogs.conf to override the configured SSL port
      • 1.0-78 - EA-5613: Remove ScriptAlias for no longer existing scgiwrap
    • ea-apr
      • 1.5.2-5 - EA-5169: libdir is removed when the rpm is uninstalled
    • ea-apr-util
      • 1.5.2-12 - EA-5718: Now depends on ea-apr, uses ns_name macro
    • mod_fcgid
      • 2.3.9-1 - First cPanel release
      • 2.3.9-2 - Added conflicts with ea-apache24-mod_ruid2.
      • 2.3.9-3 - EA-5387: Use CloudLinux patch to limit process signaling to started processes
      • 2.3.9-4 - Added conflicts with ea-apache24-mod_mpm_itk.
      • 2.3.9-5 - EA-5436: Change ownership of /run/mod_fcgid to allow httpd writes
      • 2.3.9-6 - EA-5436: Fix mod_fcgid directory for CentOS 6.
      • 2.3.9-7 - General cleanup (EA-5395), Cleans up run/mod_fcgid directory when package is uninstalled (EA-5594), Switch to rpm macros
    • mod_ruid2
      • 0.9.8-13 - EA-5429: Added conflicts with mod_fcgid.
    • mod_security2
      • 2.9.0-12 - EA-5720: Enforce apr-util dependency, ensure dependent libraries are the same arch type
    • mpm_itk
      • 2.4.7.2-5 - EA-5441: Make mod_fcid and mod_itk conflict with each other.
    • scl-php54
      • 5.4.45-23 - Ensure the same extensions are compiled statically across all SAPI types (EA-5587)
      • 5.4.45-24 - Make php-cli require php-litespeed
      • 5.4.45-25 - Fix erronous getpwnam message in php-fpm jailshell code
      • 5.4.45-26 - EA-3685: do not create apache user/group since we use nobody
    • scl-php55
      • 5.5.38-5 - Make php-cli require php-litespeed
      • 5.5.38-6 - Ensure the same extensions are compiled statically across all SAPI types (EA-5587)
      • 5.5.38-7 - Fix erronous getpwnam message in php-fpm jailshell code
      • 5.5.38-8 - EA-3685: do not create apache user/group since we use nobody
    • scl-php56
      • 5.6.28-2 - Make php-cli require php-litespeed
      • 5.6.28-3 - Ensure the same extensions are compiled statically across all SAPI types (EA-5587)
      • 5.6.28-4 - Fix erronous getpwnam message in php-fpm jailshell code
      • 5.6.28-5 - Remove fpm ondemand patch (EA-5714)
      • 5.6.28-6 - EA-3685: do not create apache user/group since we use nobody
      • 5.6.29-1 - Updated to version 5.6.29 via update_pkg.pl (EA-5777) (with fixes for CVE-2016-9935)
    • scl-php56-meta
      • 5.6.29-1 - Updated PHP version
    • scl-php70
      • 7.0.13-2 - Make php-cli require php-litespeed
      • 7.0.13-3 - Ensure the same extensions are compiled statically across all SAPI types (EA-5587)
      • 7.0.13-4 - Fix erronous getpwnam message in php-fpm jailshell code
      • 7.0.13-5 - EA-3685: do not create apache user/group since we use nobody
      • 7.0.14-1 - Updated to version 7.0.14 via update_pkg.pl (EA-5753) (with fixes for CVE-2016-5094, CVE-2016-9935, and CVE-2016-9936)
    • ea-php70-meta
      • 7.0.14-1 - EA-5754: Release 7.0.14 to match PHP 7.0 release of 7.0.14
    • scl-php71
      • 7.1.0-9.RC6 - Make php-cli require php-litespeed
      • 7.1.0-10.RC6 - Ensure the same extensions are compiled statically across all SAPI types (EA-5587)
      • 7.1.0-11.RC6 - Fix erronous getpwnam message in php-fpm jailshell code
      • 7.1.0-12.RC6 - EA-3685: do not create apache user/group since we use nobody
      • 7.1.0-13 - Update for final PHP 7.1.0 (with fixes for CVE-2016-5094, CVE-2016-9933, CVE-2016-9934, and CVE-2016-9936)
    • scl-php71-meta
      • 7.1.0-9 - New release for PHP 7.1.0
    • scl-sourceguardian
      • 11.0.6-1 - EA-5653: This commit updates the Sourceguardian loaders adding support for PHP 7.0


    EASYAPACHE 4 CHANGE LOG: EasyApache 4 Change Log - EasyApache 4 - cPanel Documentation
     
    #1 cPStacy, Dec 14, 2016
    Last edited: Dec 14, 2016
Loading...

Share This Page