test8725

Registered
Dec 20, 2019
2
0
1
HK
cPanel Access Level
Root Administrator
Hello, I am getting EasyApache 4 Update Error. Please let me know how to fix it. Thanks.

Yum is currently locked - cannot proceed at /usr/local/cpanel/cpanel/pacman.pm line 887
1.png


My server info CENTOS 7.7 kvm v84.0.15
 
Last edited by a moderator:

cPJeremy

Technical Analyst
Staff member
Feb 13, 2019
58
3
83
Houston TX
cPanel Access Level
Root Administrator
Hello!

I am sorry to hear that you are encountering this. What is most likely is that there is another process trying to use yum to update or install packages. Can you please give me the output of the following command on your server?
ps auxwwf | grep yum

Please note that sometimes this error is only temporary so you may be able to try again shortly.
 

cPSamuelM

Technical Analyst Team Lead
Staff member
Nov 20, 2019
196
38
103
USA
cPanel Access Level
Root Administrator
Hello @test8725,

The error shown in the screenshot you provided in your last update is unrelated to the error in the original screenshot you shared. You can try to find the PID of the process holding the yum lock by running the following command:

cat /var/run/yum.pid

It is possible that the process is no longer running, but yum has remained locked. In this case you could delete /var/run/yum.pid to remove the lock, however I would suggest you have your system administrator review the issue further as this could indicate other stability and performance issues with your server.

Please let us know if you have any questions.

Best regards