EasyApache - Add new php versions

BassTeQ

Well-Known Member
Aug 31, 2008
67
8
58
Hi all,

It's been a while since I've run easyApache, so I'd just like to check if what I'm doing is correct.
I'd like to keep all my existsing php versions, modules etc... and only add php 7.4, 8.X

1662588189499.png

So do I just click customize and select the below?

1662588313809.png
As I'd like to keep the same extenstions used by older versions in the new, I need to select PHP 7.4 and Extenstions

1662588420158.png

Then Provision.

Does this still recomple already existsing things like Apache 2.4 PHP v 5.6, 7.1, 7.2 etc if they're not being changed?

Thanks!
 

Attachments

Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
Yes, it's just that easy. Click the blue "Customize" button and choose what you want. Since everything is in an RPM system now it doesn't exactly "recompile" like the older versions that took several minutes to rebuild, but the new components will be installed and available.
 

BassTeQ

Well-Known Member
Aug 31, 2008
67
8
58
Thanks for the replies, so can I then assume exisitng apache will remain up and running, and existsing php versions won't be affected?

Cheers
 
  • Like
Reactions: cPRex

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
765
310
363
cPanel Access Level
DataCenter Provider
During provision it will recompile on the PHP version which you selected for installation and it extension.
And just to be "technically" correct, EasyApache does not compile any longer. It's simply using your OS's package manger to install the appropriate packages.
 
  • Like
Reactions: cPRex