Solokron

Well-Known Member
Aug 8, 2003
851
1
168
Seattle
cPanel Access Level
DataCenter Provider
It appears my previous post was removed. I have a client who who wishes to use PHP 5.3.15 for testing. Instead of recompiling everything manually, is it possible for EasyApache to be configured to download and install the older version? Custom use of opt etc?

Thank you.
 

server9host

Well-Known Member
Sep 18, 2013
160
0
16
India
cPanel Access Level
Root Administrator
Hello,

You did not install PHP version below that 5.3.29 from easyapache. Updated easyapache support above PHP 5.3.29 version.

You can install cloud linux on your server to use multiple PHP version in your server and you can easily change PHP version for each site via cPanel.

Thanks
 

ScottTh

Well-Known Member
Jan 28, 2013
157
2
18
Houston, TX
cPanel Access Level
Root Administrator
It appears my previous post was removed. I have a client who who wishes to use PHP 5.3.15 for testing. Instead of recompiling everything manually, is it possible for EasyApache to be configured to download and install the older version? Custom use of opt etc?

Thank you.
Hi Solokron,

Unsupported versions of PHP cannot being installed by EasyApache except through a custom opt mod like you mentioned.
 

Solokron

Well-Known Member
Aug 8, 2003
851
1
168
Seattle
cPanel Access Level
DataCenter Provider
Hello Scott,

How can one perform this via opt?
 

ScottTh

Well-Known Member
Jan 28, 2013
157
2
18
Houston, TX
cPanel Access Level
Root Administrator
Hello Scott,

How can one perform this via opt?
It is technically plausible to create your own PHP opt mod. It would require manually compiling PHP along with extensive Perl programming knowledge. We do not provide any technical support for opt mods. If you are interested in pursuing this I can point you to the available resources.

I believe that the much easier solution would be to upgrade the application that currently requires PHP 5.3.15. Or find an alternative application that is supported by an update version of PHP.