The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache and pcre bug !

Discussion in 'cPanel Developers' started by abdullah.masry, Nov 11, 2012.

  1. abdullah.masry

    Joined:
    Nov 11, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    hi,
    My host uses easyapache to install and upgrade their (L)AMP, however there is a bug in pcre that needs a patch :
    Bug 1187 – Pcre 8.21 issue with Vbulletin
    the technical support of the host - for some unknown reasons ! - refuses to take any action on their own, and they're waiting until the patch becomes available from upstream (cpanel) ...
    so, would you please update the script so that it applies the patch during the build process ?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,280
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Reference: EasyApache < AllDocumentation/ChangeLog < TWiki

    - Look at the 3.9.2 entry from 2012-02-13, which indicates that PCRE was patched at that time.

    My guess is that if you are still experiencing that problem, you're web host may not have recompiled Apache after PCRE was patched. You should ask them to simply re-run EasyApache within their interface to compile everything against the patched PCRE.

    M
     
  3. abdullah.masry

    Joined:
    Nov 11, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thank you for the reply, I'll contact the host and check it with them.
     
  4. abdullah.masry

    Joined:
    Nov 11, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Now there is an issue : the host has already upgraded apache and php in 30-Oct-2012, and the fix was released in 13-Feb-2012 ... is there any way he could have missed the fix ? or the fix wasn't implemented in the newer versions ?
     
  5. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,280
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I'm not sure how that could happen. If your host is on the latest version of 11.32 or 11.34 and is using the EasyApache contained within it, it _should_ build fine. Your host should open a ticket with whomever they have their ticket through.

    Im sorry I can't help you more.

    Mike
     
  6. abdullah.masry

    Joined:
    Nov 11, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thank you for the response ...
    so he should first upgrade easyapache(and cpanel), then do the rebuild, is that right ?
     
  7. abdullah.masry

    Joined:
    Nov 11, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Unfortunately -> cPanel Version : 11.34.0 (build 9) .
    any way, Thank you very much.
     

Share This Page