EasyApache and PostgreSQL support for PHP

erick_paper

Well-Known Member
Apr 19, 2005
245
0
166
Hi. I have installed PostgreSQL 9.0.4 on my server. (Cpanel is supporting only 8.1.x, which is highly recommended by PostgreSQL's own folks to be NOT used. Whatever.)

Now, with PG latest installed, the "EasyApache" doesn't seem to like the compilation of PG support in PHP.

Is this a problem? Can't I have my own PG 9.0.4 and still have the usual PHP support for PG via EasyApache? Isn't PHP support a bit more generic and completely unrelated to the version of PG that's installed? THe functions in PHP are the same, regardless of specific version of PG, so why this problem?

Would welcome any help or pointers. Thanks!
 
Last edited:

joonbug

Registered
Jul 22, 2011
1
0
51
I agree! Easyapache should be able to add Postgres support to PHP -- without the prerequisite of installing Postgres 8.

For two reasons:

1. I would prefer not to have postgres installed on certain web servers.

2. In some cases I do want postgres 9 installed on the web server and it is not desirable to install postgres 8 just to appease easyapache.

Is there a way to "trick" easyapache into thinking Postgres8 is installed?

Thanks!