The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache (Apache Update) PHP version

Discussion in 'EasyApache' started by Pedro Pinto, Aug 11, 2010.

  1. Pedro Pinto

    Pedro Pinto Registered

    Joined:
    Aug 11, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    is it possible to add different PHP versions to EasyApache?
    If affirmative, how?

    :)
     
  2. Pedro Pinto

    Pedro Pinto Registered

    Joined:
    Aug 11, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I've meant through /var/cpanel/perl/easy/Cpanel/Easy

    currently, for PHP4, it's 4_6 4_7 4_8 4_9 how can I add other versions?
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Depending on the version it may not be supported for new installation via EasyApache. As newer PHP versions are released you will find older versions are rotated out as they become obsolete or deprecated.

    What exact PHP versions you are wanting to add and why?
     
  4. Pedro Pinto

    Pedro Pinto Registered

    Joined:
    Aug 11, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Yes, I know, thanks :)

    I specific need to support a PHP 4.3.x series, due to some old code that does not work in 4.4.x.
    This would be a temporary measure, until the new website is finished, since this a account transfer from another provider.

    Thanks for the info :)
     
  5. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    In the case of a severely out-of-date script I recommend contacting the software developer or vendor from where it was obtained to have the script upgraded and overhauled to work with the latest PHP version. If there is any development work required, I believe it would be wise to make the most of the time and money involved by upgrading the script to be fully compatible running on the latest PHP version, that of PHP 5.3 at the time of writing. If the script is only updated to work with PHP 4.4, this still leaves open the possibility it may be more vulnerable to exploit and pose a greater risk to system security.

    I recommend the following resources from the PHP web site to help determine the changes that may be required:
     
Loading...

Share This Page