Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EasyApache Breaks Apache w/ IonCube

Discussion in 'EasyApache' started by CrazyTech, Dec 23, 2007.

  1. CrazyTech

    CrazyTech Member

    Joined:
    Mar 9, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    South Carolina
    I'm running (well trying to) Apache 2.2 w/ eAccelerator, IonCube, and Zend on PHP 5.2.5. Everything runs fine and Easy Apache builds fine without IonCube, but when I install ioncube I get the following when trying to start up httpd:

    Here is the output of php -v:

    I've searched the forums here, but I don't really see a fix for this. The short term solution is not to include Ioncube, but I have several sites running that use it.

    Any ideas with what I can do to get this working? It doesn't seem to be an issue with the Listen entry in httpd.conf as it's the same both when it works and when it doesn't.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. CrazyTech

    CrazyTech Member

    Joined:
    Mar 9, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    South Carolina
    Well, just an update. I tried some fixes by using PHP 5.2.3 and then even downgrading back to Apache 1.3.39, but neither approach worked. I'm going to have to find a workaround for the websites until I can get this resolved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. CrazyTech

    CrazyTech Member

    Joined:
    Mar 9, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    South Carolina
    Fixed the issue by recompiling without and then manually installing the IonCube loaders.

    PHP 5.2.5 (cli) (built: Dec 23 2007 23:26:51)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    243
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    If you can replicate this issue, please open a ticket Attn: JD so that I can have a look at the problem. I haven't been able to replicate this on any of our internal development machines and there shouldn't be any difference between EAccelerator installed by EA3 and EAccelerator installed using /scripts/phpextensionmgr.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice