Easyapache Broken, Do Not Run Until Cpanel Fix!

Status
Not open for further replies.

DIYHosting

Well-Known Member
Nov 27, 2003
60
0
156
Saskatoon, SK, Canada
There is currently an issue with easyapache where it will trash your Apache/PHP configuration if you run it at this time, so do not attempt to upgrade Apache until cPanel has confirmed that this issue has been resolved.

I've just destroyed 3 boxes now due to this. Everything was working fine this afternoon, but something went very very wrong with easyapache at some point this evening...
 

binaer

Well-Known Member
Jul 6, 2004
60
0
156
I've tried it last Saturday and it has not compiled "IMAP" into PHP even I've checked the box
 

DIYHosting

Well-Known Member
Nov 27, 2003
60
0
156
Saskatoon, SK, Canada
After running /scripts/easyapache on my PHP4 based servers (without PHPSuExec) this got Apache/PHP back up and running with the previous configuration:

cd /usr/src
wget ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/libmcrypt/libmcrypt-2.5.7.tar.gz
tar -zxf libmcrypt-2.5.7.tar.gz
cd libmcrypt-2.5.7
./configure --prefix=/usr
make
make install
service httpd restart

I had to hire a server admin to manually recompile Apache/PHP on my PHP5 servers with PHPSuExec to get them back up.
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
Is there any fix for this?

Right now, on my clients server, php is totaly broken.... When i try to open a php file in IE, it trys to save the file to disk....

What are the problems everyone else is having with php? the same as above?
 

DIYHosting

Well-Known Member
Nov 27, 2003
60
0
156
Saskatoon, SK, Canada
I should also note that I upgraded successfully to Apache 1.3.36 and PHP 5.1.4 this afternoon but when I tried to upgrade some other servers this evening, all of them (both PHP 4 and 5) were trashed by easyapache.
 

jackie46

BANNED
Jul 25, 2005
537
0
166
I'v complained about Easyapache for weeks. The problem is unless you run easyapache under versbose mode you wont see all the stupid errors coming from all the php modules you've selected, THAT DO NOT COMPILE DUE TO ERRORS! Flash and many others do not compile CLEAN! Therefore, once its finished a whole bunch of error arise and php among many other things will fail to either upgrade or run.

Incredible!
 

DIYHosting

Well-Known Member
Nov 27, 2003
60
0
156
Saskatoon, SK, Canada
cpanelnick said:
There are known problems with mysql which prevent php 5 for compiling. New mysql rpms should be out shortly:

http://bugs.mysql.com/bug.php?id=16595
http://bugs.mysql.com/bug.php?id=15255
Nick,

I should note that this is not related to the MySQL libz.la errors when compiling PHP 5 and MySQL 4.1. I was able to fix that with the following:

cd /usr/src
wget http://downloads.mysql.com/archives/mysql-4.1/MySQL-devel-4.1.13-0.glibc23.i386.rpm
rpm -Uvh --force MySQL-devel-4.1.13-0.glibc23.i386.rpm
service mysql restart
This is a completely different issue that just started this evening.
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
Nick, This is not an issue with php5 only... as my server runs php4, and has never ran php5, and this issue still happens to me...

I have a few very upset clients because of this issue. I will not update anymore servers untill this issue has been resolved.
 

gemby

Well-Known Member
PartnerNOC
Feb 16, 2002
182
0
316
Pula, Croatia
cPanel Access Level
DataCenter Provider
One more thing, i tried just one box, but i got completly diferent error...


Resolving layer1.cpanel.net... 69.72.164.152, 69.72.164.155, 69.90.250.34, ...
Connecting to layer1.cpanel.net|69.72.164.152|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10,682,299 (10M) [audio/x-pn-realaudio-plugin]

100%[====================================>] 10,682,299 820.02K/s ETA 00:00

09:05:15 (815.02 KB/s) - `/var/spool/cpupdates/frontpage-5.2-0.i386.rpm' saved [10682299/10682299]

error: open of /var/spool/cpupdates/frontpage-2002-SR1.2.i386.rpm failed: No such file or directory
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
I GOT IT WORKING!!!!!


This is what i did:

I updated cpanel to the latest Bleeding EDGE release.

Then after that update completed, i ran /scripts/easyapache

When the options come up, i used option "6 - Advanced"

Then when the window came up that i select what i want compiled, uncheck "Skip apache build if up to date" and i left everything else as default.


This is a workaround untill cpanel fixes this issue, so some php scripts thst use special features compiled into apache wont work, but at least you wont have "as many" clients complaining.
 

jackie46

BANNED
Jul 25, 2005
537
0
166
Thats not necessarily the fix. It may have worked for you but many are not running Edge.

Glad i stayed away from any updates. All my boxes are running. Let the pigs, i mean guinea pigs be pigs.

OINK OINK!
 
Last edited:

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
I never said it was "the" fix... I said it was a temprary fix, as it worked for me.


It may even work without upgrading to the EDGE release, i dont know, i didnt try it, so if anyone wants to try it, try the above, but skip the update to edge.
 

dave9000

Well-Known Member
Apr 7, 2003
891
1
168
arkansas
cPanel Access Level
Root Administrator
easyapache is not working for me on EDGE even using option 6

support ticket has been submitted

1) Beginner without/phpsuexec + webroot protection support (*** DEFAULT ***)
2) Beginner with/phpsuexec support + web root protection
3) Beginner with/php mcrypt support (if php will not compile, you must choose option 1)
4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)
5) Beginner with/php gd+freetype+mcrypt support (if php will not compile, you must choose option 1)
6) Advanced (Experts Only, At Your Own Risk)
7) Advanced [Load Previous Config] (Experts Only, At Your Own Risk)
8) Failsafe mode (Resets apache config to default, USE ONLY AS A LAST RESORT)
---->6
Undefined argument in option spec
Undefined argument in option spec
Building lxdialog failed at ./buildapache line 200.
Untarring expat...02:42:53 URL:http://layer1.cpanel.net/buildapache/1/expat-1.95.6.tar.gz [291876/291876] -> "expat-1.95.6.tar.gz" [1]
Done
Undefined argument in option spec
Undefined argument in option spec
Undefined argument in option spec
 

techark

Well-Known Member
May 22, 2002
280
0
316
I am now geetting the same stuff and dave9000 submited a ticket.

I upgraded 20 other servers with out a problem then this.

Come on cpanel whats going on what changed in the last hour?
 

techark

Well-Known Member
May 22, 2002
280
0
316
My apache is working but phpsuexec is dead as a door nail. Internal 500 errors or 404 errors on ever php site. HTML sites work fine.
 
Status
Not open for further replies.