The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache downloads file

Discussion in 'EasyApache' started by jpganz18, Sep 7, 2011.

  1. jpganz18

    jpganz18 Registered

    Joined:
    Sep 7, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I have a Centos server, I got an error on createimage function, which was supposed to be installed, so, I went to the easy apache and check it out, and tried to recompile the apache and php modules, (DG) , but it was showing me an error, looking it out on this forum I got someone who ran this:

    Do not run the command below as it will cause yum.conf to be wiped for the exclude line!

    sed -i -e's/^exclude=.*//' /etc/yum.con

    It worked fine, but the when I try to enter to the EasyApache option it downloads a file, a .pl one, like when you dont have allow extensions and downloads the phps... but this time with this file, I dont know whats the problem, did anybody got the same problem before?

    thanks
     
    #1 jpganz18, Sep 7, 2011
    Last edited by a moderator: Sep 8, 2011
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I do not understand the thread entirely. Is DG actually GD and is the command indicated would wipe your yum.conf file for the exclude line and it is yum.conf rather than yum.con

    I would be really wary of running commands that are noted online by people, especially those wiping lines from /etc/yum.conf file

    If your images aren't working with GD function, yum.conf does not have anything to do with that occurring. You'd want to check if PHP has GD installed:

    Code:
    php -m | grep -i gd
    As for when you try to enter EasyApache, what is meant by enter EasyApache? When you try to run EasyApache in WHM, it is trying to download a file rather than run the recompiler GUI interface? If so, please post the output when trying to run it for errors in the log file:

    Code:
    tail -fn0 /usr/local/cpanel/logs/error_log
    Finally, can you try to run this command in root SSH to see if it does work?

    Code:
    /scripts/easyapache
    Thanks!
     
Loading...

Share This Page