The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache Error or Bug with Apache 2.4+PHP5.4

Discussion in 'EasyApache' started by VirtuaLira, Dec 26, 2013.

  1. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Hello guys, I'm trying to compile Apache 2.4+PHP 5.4 but, the EasyApache doesn't make the complete process throwing an error.

    Anyone have this issue? is maybe a problem of the modules or PHP extensions selected?
     
  2. Shavaun

    Shavaun Well-Known Member

    Joined:
    Aug 15, 2013
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    You should be able to use Apache 2.4 with PHP 5.4. Can you provide the error message that EasyApache is producing?

    Although EasyApache is designed to alert you to incompatible modules, for reference you can view a list of the Apache modules and their compatibility with versions of Apache here: EasyApache: Apache Modules.

    You can view a list of the PHP modules and which versions they are compatible with here: EasyApache: PHP Modules.
     
  3. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Generates a report:
    Build id: 1388066324.
    Report id: 12584151

    chmod 755 /usr/local/apache/modules/mod_bwlimited.so
    apxs:Error: Activation failed for custom /usr/local/apache/conf/httpd.conf file..
    apxs:Error: At least one `LoadModule' directive already has to exist..
    !! '/usr/local/apache/bin/apxs -i -a -c ../mod_bwlimited.c' failed with exit code '256' !!
     
  4. Shavaun

    Shavaun Well-Known Member

    Joined:
    Aug 15, 2013
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
  5. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Yes, uninstalling now, I will try again! Thanks.

    - - - Updated - - -

    Solved! thanks Shavaun
     
  6. Shavaun

    Shavaun Well-Known Member

    Joined:
    Aug 15, 2013
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I'm glad we could help! Let us know if you run into any other difficulties.
     
Loading...

Share This Page