The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache is error

Discussion in 'EasyApache' started by jazz1611, Jun 5, 2012.

  1. jazz1611

    jazz1611 Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I tried update with EasyApache but it show error. Please help me!

    Code:
    If the browser window is closed or stopped the build will continue in the background.
    The build output should start shortly...
    
    Distilled successfully
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1338930472' !!
    !!
    Output from '/bin/sh -c "ulimit -a"':
    core file size          (blocks, -c) 0
    data seg size           (kbytes, -d) unlimited
    scheduling priority             (-e) 0
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 135168
    max locked memory       (kbytes, -l) 32
    max memory size         (kbytes, -m) 524288
    open files                      (-n) 1024
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    real-time priority              (-r) 0
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 135168
    virtual memory          (kbytes, -v) 524288
    file locks                      (-x) unlimited
    !!
    !! Creating backup of working apache in '/usr/local/apache.backup'. !!
    !! Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!
    
    !! Backup of working apache complete. !!
    Checking that all tarballs are present and up to date.
    Checking that all packages are present and up to date.
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.5ninesolutions.com
    * extras: mirror.stanford.edu
    * updates: mirror.5ninesolutions.com
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Package gettext-0.17-1.el5.x86_64 already installed and latest version
    Package gettext-0.17-1.el5.i386 already installed and latest version
    No package automake19 available.
    Package libstdc++-4.1.2-52.el5_8.1.x86_64 already installed and latest version
    Package readline-devel-5.1-3.el5.x86_64 already installed and latest version
    Package readline-devel-5.1-3.el5.i386 already installed and latest version
    Package 2:libpng-devel-1.2.10-17.el5_8.x86_64 already installed and latest version
    Package 2:libpng-devel-1.2.10-17.el5_8.i386 already installed and latest version
    Package fontconfig-2.4.1-7.el5.x86_64 already installed and latest version
    Package fontconfig-2.4.1-7.el5.i386 already installed and latest version
    Package openssl-0.9.8e-22.el5_8.4.x86_64 already installed and latest version
    Package openssl-0.9.8e-22.el5_8.4.i686 already installed and latest version
    Package zlib-devel-1.2.3-4.el5.x86_64 already installed and latest version
    Package zlib-devel-1.2.3-4.el5.i386 already installed and latest version
    No package libpng-dev available.
    No package autoconf261 available.
    Package giflib-devel-4.1.3-7.3.3.el5.x86_64 already installed and latest version
    Package giflib-devel-4.1.3-7.3.3.el5.i386 already installed and latest version
    Package libidn-devel-0.6.5-1.1.x86_64 already installed and latest version
    Package libidn-devel-0.6.5-1.1.i386 already installed and latest version
    No package gmake available.
    Package libidn-0.6.5-1.1.x86_64 already installed and latest version
    Package libidn-0.6.5-1.1.i386 already installed and latest version
    Package openssl-devel-0.9.8e-22.el5_8.4.x86_64 already installed and latest version
    Package openssl-devel-0.9.8e-22.el5_8.4.i386 already installed and latest version
    Package automake-1.9.6-2.3.el5.noarch already installed and latest version
    Package coreutils-5.97-34.el5_8.1.x86_64 already installed and latest version
    Package tcl-8.4.13-4.el5.x86_64 already installed and latest version
    Package tcl-8.4.13-4.el5.i386 already installed and latest version
    Package patch-2.5.4-31.el5.x86_64 already installed and latest version
    No package libltdl3-devel available.
    No package libltdl available.
    No package libopenssl0.9.7-static-devel available.
    No package readline-dev available.
    Package libtool-ltdl-devel-1.5.22-7.el5_4.x86_64 already installed and latest version
    Package libtool-ltdl-devel-1.5.22-7.el5_4.i386 already installed and latest version
    Package sed-4.1.5-8.el5.x86_64 already installed and latest version
    Package freetype-2.2.1-31.el5_8.1.x86_64 already installed and latest version
    Package freetype-2.2.1-31.el5_8.1.i386 already installed and latest version
    Package lsof-4.78-6.x86_64 already installed and latest version
    No package krb5-dev available.
    Package flex-2.5.4a-41.fc6.x86_64 already installed and latest version
    No package glibc-dev available.
    No package expat-dev available.
    Package krb5-devel-1.6.1-70.el5.x86_64 already installed and latest version
    Package krb5-devel-1.6.1-70.el5.i386 already installed and latest version
    No package libstdc++-devel.x64_64 available.
    No package xorg-x11-devel available.
    Package giflib-4.1.3-7.3.3.el5.x86_64 already installed and latest version
    Package giflib-4.1.3-7.3.3.el5.i386 already installed and latest version
    Package libtool-ltdl-1.5.22-7.el5_4.x86_64 already installed and latest version
    Package libtool-ltdl-1.5.22-7.el5_4.i386 already installed and latest version
    No package libssl-dev available.
    Package pam-devel-0.99.6.2-6.el5_5.2.x86_64 already installed and latest version
    Package pam-devel-0.99.6.2-6.el5_5.2.i386 already installed and latest version
    No package libopenssl0-devel available.
    No package zlib1-devel available.
    Package expat-devel-1.95.8-8.3.el5_5.3.x86_64 already installed and latest version
    Package expat-devel-1.95.8-8.3.el5_5.3.i386 already installed and latest version
    Package freetype-devel-2.2.1-31.el5_8.1.x86_64 already installed and latest version
    Package freetype-devel-2.2.1-31.el5_8.1.i386 already installed and latest version
    No package libopenssl0-dev available.
    Package expat-1.95.8-8.3.el5_5.3.x86_64 already installed and latest version
    Package expat-1.95.8-8.3.el5_5.3.i386 already installed and latest version
    Package libXrender-0.9.1-3.1.x86_64 already installed and latest version
    Package libXrender-0.9.1-3.1.i386 already installed and latest version
    Package zlib-1.2.3-4.el5.x86_64 already installed and latest version
    Package zlib-1.2.3-4.el5.i386 already installed and latest version
    Package bison-2.3-2.1.x86_64 already installed and latest version
    Package libjpeg-devel-6b-37.x86_64 already installed and latest version
    Package libjpeg-devel-6b-37.i386 already installed and latest version
    No package libtool-libltdl-devel available.
    Package libtool-1.5.22-7.el5_4.x86_64 already installed and latest version
    No package openssl-dev available.
    No package libopenssl0 available.
    No package libz-devel available.
    No package libjpeg-dev available.
    No package pam-dev available.
    Package coreutils-5.97-34.el5_8.1.x86_64 already installed and latest version
    No package libltdl-devel available.
    No package libopenssl0.9.7-devel available.
    Package e2fsprogs-devel-1.39-33.el5.x86_64 already installed and latest version
    Package e2fsprogs-devel-1.39-33.el5.i386 already installed and latest version
    No package ca_root_nss available.
    Package 1:make-3.81-3.el5.x86_64 already installed and latest version
    No package libstdc++-dev.x86_64 available.
    Package libX11-devel-1.0.3-11.el5_7.1.x86_64 already installed and latest version
    Package libX11-devel-1.0.3-11.el5_7.1.i386 already installed and latest version
    Package libstdc++-devel-4.1.2-52.el5_8.1.x86_64 already installed and latest version
    Package libXrender-devel-0.9.1-3.1.x86_64 already installed and latest version
    Package libXrender-devel-0.9.1-3.1.i386 already installed and latest version
    Package cpp-4.1.2-52.el5_8.1.x86_64 already installed and latest version
    No package xorg-x11-dev available.
    No package ssl-dev available.
    No package lex available.
    Package autoconf-2.59-12.noarch already installed and latest version
    Package fontconfig-devel-2.4.1-7.el5.x86_64 already installed and latest version
    Package fontconfig-devel-2.4.1-7.el5.i386 already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    ---> Package gcc.x86_64 0:4.1.2-52.el5_8.1 set to be updated
    ---> Package gcc-c++.x86_64 0:4.1.2-52.el5_8.1 set to be updated
    ---> Package glibc-devel.i386 0:2.5-81.el5_8.2 set to be updated
    --> Processing Dependency: glibc-headers = 2.5-81.el5_8.2 for package: glibc-devel
    --> Processing Dependency: glibc-headers for package: glibc-devel
    ---> Package glibc-devel.x86_64 0:2.5-81.el5_8.2 set to be updated
    --> Running transaction check
    ---> Package glibc-headers.x86_64 0:2.5-81.el5_8.2 set to be updated
    --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers
    --> Processing Dependency: kernel-headers for package: glibc-headers
    --> Finished Dependency Resolution
    glibc-headers-2.5-81.el5_8.2.x86_64 from updates has depsolving problems
      --> Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)
    glibc-headers-2.5-81.el5_8.2.x86_64 from updates has depsolving problems
      --> Missing Dependency: kernel-headers is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)
    Error: Missing Dependency: kernel-headers is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)
    Error: Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    !! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!
    
    !! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!
    
    !! Could not ensure pkglist 'gettext, automake19, libstdc++.x86_64, readline-devel, libpng-devel, fontconfig, openssl, zlib-devel, libpng-dev, autoconf261, giflib-devel, libidn-devel, gmake, libidn, openssl-devel, automake, coreutils, tcl, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, readline-dev, libtool-ltdl-devel, sed, freetype, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, libstdc++-devel.x64_64, xorg-x11-devel, giflib, libtool-ltdl, libssl-dev, pam-devel, libopenssl0-devel, zlib1-devel, expat-devel, freetype-devel, libopenssl0-dev, gcc-c++, glibc-devel, expat, libXrender, zlib, bison, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, e2fsprogs-devel, ca_root_nss, make, libstdc++-dev.x86_64, libX11-devel, libstdc++-devel.x86_64, libXrender-devel, cpp, xorg-x11-dev, gcc, ssl-dev, lex, autoconf, fontconfig-devel' !!
    !! The server's system package manager, 'YUM', failed. !!
    
    !!
    This is the command that failed: yum --exclude=kernel* -y install gettext automake19 libstdc++.x86_64 readline-devel libpng-devel fontconfig openssl zlib-devel libpng-dev autoconf261 giflib-devel libidn-devel gmake libidn openssl-devel automake coreutils tcl patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel sed freetype lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel giflib libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel freetype-devel libopenssl0-dev gcc-c++ glibc-devel expat libXrender zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 libXrender-devel cpp xorg-x11-dev gcc ssl-dev lex autoconf fontconfig-devel !!
    
    !!
    Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at [url=http://www.cpanel.net/support/could_not_ensurepkgs.htm]EaError < AllDocumentation < TWiki[/url] 3) Resolve the YUM problem manually 4) Re-run EasyApache !!
    
    !! Please visit [url=http://www.cpanel.net/support/could_not_ensurepkgs.htm]EaError < AllDocumentation < TWiki[/url] for help with this error. !!
    
    !! Restoring original working apache !!
    
    !! Executing '/scripts/initsslhttpd' !!
    !! Restarting 'httpd' ... !!
    !! 'httpd' restart complete. !!
    Building global cache for cpanel...Done
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/update_apachectl' !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1338930472' !!
     
  2. morissette

    morissette Well-Known Member

    Joined:
    May 24, 2009
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin, TX
    cPanel Access Level:
    Root Administrator
    looks like the issue is with yum, did you try the recommendations above, then re-running? Is yum working outside of EA?
     
Loading...

Share This Page