Status
Not open for further replies.

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,427
2,113
363
cPanel Access Level
Root Administrator
We are happy to announce that cPanel, L.L.C. has released an update for EasyApache 4! Take a look at some highlights below, and then join us on the cPanel Community Forums, Discord, or Reddit to talk about this update and much more. If you have additional questions, feel free to reach out on one of our social channels.
  • ea-cpanel-tools
    • ZC-10581: update ea4 recommendations
    • ZC-10447: make PHP 8.1 the default PHP
    • ZC-10447: update manifest for A9 and PHP 8.2
  • ea-nginx
    • EA-10890: Refactor _render_and_append() to use more data from global config data
    • EA-11121: Add ipv6 subdomain to server_name directive when account has an ipv6 address assigned
    • EA-11088: Account for mail subdomains of addon and parked domains when configuring the server_name directive
    • ZC-10593: Merge last upstream bit into ea-nginx
    • ZC-10517: Address Ubuntu creating additional splitlog processes
    • ZC-10484: Remove SIGKILL from various nginx files
    • ZC-10317: Update ngx_http_pipelog_module to v1.0.3
  • ea-php80
  • ea-php80-meta
    • EA-11137: Update ea-php80 from v8.0.26 to v8.0.27
    • PDO::quote() may return unquoted string). (CVE-2022-31631)
  • ea-php81
  • ea-php81-meta
    • EA-11133: Update ea-php81 from v8.1.13 to v8.1.14
    • PDO::quote() may return unquoted string). (CVE-2022-31631)
  • ea-php82
  • ea-php82-meta
    • EA-11136: Update ea-php82 from v8.2.0 to v8.2.1
    • PDO::quote() may return unquoted string). (CVE-2022-31631)
  • ea-profiles-cpanel
    • ZC-10447: Update profiles for PHP 7.4 being EOL and PHP 8.2 being available
  • ea-ruby27-rubygem-rack
    • EA-11119: Update ea-ruby27-rubygem-rack from v2.2.4 to v2.2.5
  • ea-apache24-mod-qos
    • EA-11147: Update ea-apache24-mod-qos from v11.72 to v11.73
This release includes a security patch that has been issued a fix for a CVE (Common Vulnerabilities and Exposures), the details of which are included below.

SUMMARY
cPanel, L.L.C. has updated packages for EasyApache 4 with PHP versions 8.0.26, 8.1.14, and 8.2.1. This release addresses vulnerabilities related to CVE-2022-31631. We strongly encourage all PHP 8.0 users to upgrade to version 8.0.26, all PHP 8.1 users to upgrade to version 8.1.14, and all PHP 8.2 users to update to version 8.2.1.

AFFECTED VERSIONS
All versions of PHP 8.0 through 8.0.25.
All versions of PHP 8.1 through 8.1.13.
All versions of PHP 8.2 through 8.0.0.

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:
CVE-2022-31631 – MEDIUM
PHP 8.0.26
Fixed vulnerability related to CVE-2022-31631.
PHP 8.1.14
Fixed vulnerability related toCVE-2022-31631.
PHP 8.2.1
Fixed vulnerability related to CVE-2022-31631.

SOLUTION
cPanel, L.L.C. has released updated packages for EasyApache 4 on January 11, 2023, with PHP versions 8.0.26, 8.1.14, and 8.2.1. Unless you have enabled automatic package updates in your cron, update your system with either your package manager or WHM’s Run System Update interface.

REFERENCES
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31631
https://www.php.net/ChangeLog-8.php#8.0.27
https://www.php.net/ChangeLog-8.php#8.1.14
https://www.php.net/ChangeLog-8.php#8.2.1

https://news.cpanel.com/wp-content/uploads/2023/01/EA4-2023-1-11-CVE.signed.txt
 
  • Like
Reactions: DennisMidjord
Status
Not open for further replies.