The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easyapache no longer working in 11.28.13?

Discussion in 'EasyApache' started by johnburk, Nov 1, 2010.

  1. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Since the upgrade to 11.28.x (which is a great improvement) it seems that easyapache nolonger works.

    I get a fatal error because apache will not restart, but the strange thing is that apache does restart

    Code:
    Apache Restart Output:
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Anyone else have a similar problem?

    @mods,
    Sorry it is in the wrong forum. I was looking a different area's and must have refresh at the wrong point.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is this happening on multiple EasyApache recompiles or you only tried it once? It appears to indicate it cannot open the log files. Please check that /usr/local/apache/domlogs and /usr/local/apache/logs both exist and both show the following permissions and ownership:

    Code:
    [root@itchy:/] # ls -ld /usr/local/apache/domlogs
    drwx--x--x  25 root wheel 4096 Nov  1 14:42 /usr/local/apache/domlogs
    
    [root@itchy:/] # ls -ld /usr/local/apache/logs
    drwxr-xr-x  4 root root 4096 Oct 31 16:52 /usr/local/apache/logs
    If they do, then try tailing the Apache error log to see if it gives any more details while restarting Apache:

    Code:
    tail -f /usr/local/apache/logs/error_log
    If it doesn't, it's probably time to strace starting it up to see if some domain has a missing log file or some domain has a corrupted log file. The command to strace is the following:

    Code:
    strace -vvf -s 4096 -o /root/strace.httpd /usr/local/apache/bin/apachectl -k start -DSSL
    Only use this command if Apache is showing that same error on restart attempts. If it isn't, then there's no point of running the strace, since it's only during EasyApache when it occurred. If it is showing that error on restart attempts about the log files, then after you run the strace, you'll want to check the strace file at /root/strace.httpd toward the end looking for log files that are missing. You can open an strace in vi at the end of the file using:

    Code:
    vi + /root/strace.httpd
    Then scroll back to view the output. strace produces a high volume of output, so if you aren't familiar with using strace, you might want to provide the last 1000-2000 lines of the strace as a txt attachment here.
     
Loading...

Share This Page