The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache No Longer Working

Discussion in 'EasyApache' started by owine, Oct 9, 2007.

  1. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    It looks as if the way EasyApache discovers packages in FreeBSD has been changed to search ports. With this change, EasyApache is no longer working on my server. It always seems to stop after searching for a certain package and the install does not continue.
     
  2. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Here's the log:

    [root@apollo /usr/home/owine]# cat /usr/local/cpanel/logs/easy/apache/build.1191968812
    !! Pre allocation testing was successfully able to allocate 90MB !!
    !!
    Ouput from '/bin/sh -c "ulimit -a"':
    cpu time (seconds, -t) unlimited
    file size (512-blocks, -f) unlimited
    data seg size (kbytes, -d) 524288
    stack size (kbytes, -s) 65536
    core file size (512-blocks, -c) unlimited
    max memory size (kbytes, -m) unlimited
    locked memory (kbytes, -l) unlimited
    max user processes (-u) 5547
    open files (-n) 11095
    virtual mem size (kbytes, -v) unlimited
    sbsize (bytes, -b) unlimited
    !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1191968812' !!
    !!
    Ouput from '/bin/sh -c "ulimit -a"':
    cpu time (seconds, -t) unlimited
    file size (512-blocks, -f) unlimited
    data seg size (kbytes, -d) 524288
    stack size (kbytes, -s) 65536
    core file size (512-blocks, -c) 1048576
    max memory size (kbytes, -m) 524288
    locked memory (kbytes, -l) unlimited
    max user processes (-u) 5547
    open files (-n) 11095
    virtual mem size (kbytes, -v) 524288
    sbsize (bytes, -b) unlimited
    !!
    !! Skipping backup, no working apache found !!

    !! Start: Silent httpupdate request !!


    !! End: Silent httpudpate request !!

    Checking that all tarballs are present and up to date.
    Checking that all packages are present and up to date.
    Creating package version list....(cached version is too old)...Done
    Searching ports for zlib1-devel ................................................................................Done
    Regexp Searching ports for zlib1-devel................................................................................Done
    Unable to upgrade zlib1-devel
    gettext is installed
    Searching ports for libpng-devel ................................................................................Done
    Regexp Searching ports for libpng-devel................................................................................Done
    Unable to upgrade libpng-devel
    Searching ports for libopenssl0-dev ................................................................................Done
    Regexp Searching ports for libopenssl0-dev................................................................................Done
    Unable to upgrade libopenssl0-dev
    openssl is installed
    Searching ports for gcc-c++ ................................................................................Done
    Regexp Searching ports for gcc-c++................................................................................Done
    Unable to upgrade gcc-c++
    Searching ports for glibc-devel ................................................................................Done
    Regexp Searching ports for glibc-devel................................................................................Done
    Unable to upgrade glibc-devel
    Searching ports for zlib-devel ................................................................................Done
    Regexp Searching ports for zlib-devel................................................................................Done
    Unable to upgrade zlib-devel
    Searching ports for libstdc++ ................................................................................Done
    Regexp Searching ports for libstdc++................................................................................Done
    Unable to upgrade libstdc++
    Searching ports for zlib ................................................................................Done
    Regexp Searching ports for zlib................................................................................Done
    Unable to upgrade zlib
    bison is installed
    Searching ports for libidn-devel ................................................................................Done
    Regexp Searching ports for libidn-devel................................................................................Done
    Unable to upgrade libidn-devel
    libidn is installed
    gmake is installed
    libXpm is installed
    Searching ports for libstdc++-devel ................................................................................Done
    Regexp Searching ports for libstdc++-devel................................................................................Done
    Unable to upgrade libstdc++-devel
    Searching ports for libjpeg-devel ................................................................................Done
    Regexp Searching ports for libjpeg-devel................................................................................Done
    Unable to upgrade libjpeg-devel
    Searching ports for openssl-devel ................................................................................Done
    Regexp Searching ports for openssl-devel................................................................................Done
    Unable to upgrade openssl-devel
    automake is installed
    coreutils is installed
    Searching ports for libtool-libltdl-devel ................................................................................Done
    Regexp Searching ports for libtool-libltdl-devel................................................................................Done
    Unable to upgrade libtool-libltdl-devel
    Searching ports for libopenssl0 ................................................................................Done
    Regexp Searching ports for libopenssl0................................................................................Done
    Unable to upgrade libopenssl0
    Searching ports for openssl-dev ................................................................................Done
    Regexp Searching ports for openssl-dev................................................................................Done
    Unable to upgrade openssl-dev
    libtool is installed
    patch is installed
    Searching ports for libz-devel ................................................................................Done
    Regexp Searching ports for libz-devel................................................................................Done
    Unable to upgrade libz-devel
    Searching ports for libstdc++-dev ................................................................................Done
    Regexp Searching ports for libstdc++-dev................................................................................Done
    Unable to upgrade libstdc++-dev
    Searching ports for libltdl3-devel ................................................................................Done
    Regexp Searching ports for libltdl3-devel................................................................................Done
    Unable to upgrade libltdl3-devel
    libltdl is installed
    Searching ports for libopenssl0.9.7-static-devel ................................................................................Done
    Regexp Searching ports for libopenssl0.9.7-static-devel................................................................................Done
    Unable to upgrade libopenssl0.9.7-static-devel
    Searching ports for pam-dev ................................................................................Done
    Regexp Searching ports for pam-dev................................................................................Done
    Unable to upgrade pam-dev
    Searching ports for libtool-ltdl-devel ................................................................................Done
    Regexp Searching ports for libtool-ltdl-devel................................................................................Done
    Unable to upgrade libtool-ltdl-devel
    Searching ports for libopenssl0.9.7-devel ................................................................................Done
    Regexp Searching ports for libopenssl0.9.7-devel................................................................................Done
    Unable to upgrade libopenssl0.9.7-devel
    Searching ports for libltdl-devel ................................................................................Done
    Regexp Searching ports for libltdl-devel................................................................................Done
    Unable to upgrade libltdl-devel
    Searching ports for fileutils ................................................................................Done
    Regexp Searching ports for fileutils................................................................................Done
    Unable to upgrade fileutils
    Searching ports for sed ................................................................................Done
    Regexp Searching ports for sed...............................found sed in /usr/ports/devel/sedsed....Done
    sed (1.0) is already installed.
    Searching ports for mysql-devel ................................................................................Done
    Regexp Searching ports for mysql-devel................................................................................Done
    Unable to upgrade mysql-devel
    Searching ports for krb5-dev ................................................................................Done
    Regexp Searching ports for krb5-dev................................................................................Done
    Unable to upgrade krb5-dev
    flex is installed
    Searching ports for glibc-dev ................................................................................Done
    Regexp Searching ports for glibc-dev................................................................................Done
    Unable to upgrade glibc-dev
    Searching ports for krb5-devel ................................................................................Done
    Regexp Searching ports for krb5-devel.........................................................................!! Continuing Build in background !!
     
  3. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Also to add:

    [root@apollo /usr/home/owine]# /scripts/easyapache --version
    Easy::Apache v3.2.0 Build 2543

    [cpanel]
    11.15.0-CURRENT_17588


    [apache]


    [server]
    FreeBSD apollo.owine.net 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Aug 31 03:28:57 CDT 2007 root@apollo:/usr/obj/usr/src/sys/apollo i386
     
  4. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    Very strange. Do the last few lines of /usr/local/cpanel/logs/easy/apache/build.1191968812 give any indication why it's stopping?
     
  5. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Nope. What I have pasted is the full log file.
     
  6. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Would I be better off opening a bug/ticket to get this solved?
     
  7. Voltar

    Voltar Well-Known Member

    Joined:
    Apr 30, 2007
    Messages:
    269
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Bakersfield, California
    Most likely yes, and post the ticket number here in case another tech sees it.
     
  8. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    I have posted it as a ticket. The ticket id is 216867.
     
  9. jthomson@liquid

    jthomson@liquid Registered
    PartnerNOC

    Joined:
    Sep 14, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Possible fix

    I had this problem and fixed it by removing glibc-dummy, which was blocking updates on a CentOS server.
     
Loading...

Share This Page