The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easyapache not working

Discussion in 'EasyApache' started by alrock, Jan 18, 2005.

  1. alrock

    alrock Active Member

    Joined:
    May 31, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I guess it's time to hire somebody to clean up and fix up my server because I can't seem to get these problems fixed, and my former server admin cannot figure them out either.

    The first problem is easyapache.

    I tried to upgrade php to 4.3.10 using easyapache and I received this error:

    configure php-4.3.10...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-mcrypt --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib).................Done
    configure: error: Problem with libXpm.(a|so) or libX11.(a|so). Please check config.log for more information.


    The .so files ARE there and attempting to reinstall the RPM's did not help.

    So, I upgraded to edge and ran updates and now when I try to run easyapache I get this:

    root@elements [~]# /scripts/easyapache
    buildapache.sea: buildapache.sea: No such file or directory

    But easyapache is there.

    Also, I tried to update apache from within WHM, even making sure the "Skip if apache is up to date" was not checked and all it does is restart apache. It does not update.

    Ideas? Anybody?
     
    #1 alrock, Jan 18, 2005
    Last edited: Jan 18, 2005
  2. bman

    bman Well-Known Member

    Joined:
    Dec 28, 2003
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    try
    /scripts/updatenow -v
    then
    /scripts/easyapache
     
  3. alrock

    alrock Active Member

    Joined:
    May 31, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Ha, I had tried all of those and it did not work.

    Then I realized I am such an idiot. I had wget permissions set to 0600. I changed it back to 0700 and easyapache ran just fine.
     
Loading...

Share This Page