The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache on RHEL withOUT up2date?

Discussion in 'EasyApache' started by vmann, Jun 1, 2006.

  1. vmann

    vmann Member
    PartnerNOC

    Joined:
    Jun 17, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I run a few cPanel virtuozzo VPS's on RHEL AS3. As we've had problems with up2date in the past, we don't install it anymore, and instead just use vzpkgadd to update templates outside of cPanel.

    Today I needed to recompile Apache to update PHP/mysql, but get this error:
    Code:
    Your operating system's rpm update method (up2date) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you
    can proceed. Please correct the conflicts and try again!
    I'd rather not install up2date if I can avoid it, does anyone know a way to tell easyapache to skip this update check?

    Thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Since up2date is a requirement for RHE on cPanel servers so that it can ensure it has the rpms/version it needs, there's not a great deal you can do apart from using it. Might be better to move over to CentOS instead and your own yum mirror on a VPS.
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    You could force updates via some other method that cpanel supports
    ie

    touch /var/cpanel/useyum
     
  4. vmann

    vmann Member
    PartnerNOC

    Joined:
    Jun 17, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ah! I didn't realize I could tell it to use another update method! Thanks!

    Also, thanks Chirpy (somehow I knew you would be the first to reply :D ) but changing OS is not an option in this situation. (I wish!)
     
  5. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Same here

    I have the same problem Here, but i have a RHE sistem. If i try to execute:

    root@server [/]# up2date install glibc

    I receive this error:

    Error Message:
    Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3 or later)
    as root on this client
    Error Class Code: 9
    Error Class Info: Invalid System Credentials.
    Explanation:
    An error has occurred while processing your request. If this problem
    persists please enter a bug report at bugzilla.redhat.com.
    If you choose to submit the bug report, please be sure to include
    details of what you were trying to do when this error occurred and
    details on how to reproduce this problem.
     
  6. vmann

    vmann Member
    PartnerNOC

    Joined:
    Jun 17, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    You have up2date installed, but not registered with the red hat network. Run 'rhn_register' or 'up2date --register' to do so.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    ...or contact your datacenter if they provided you with the server and the OS installed and have them fix it.
     
  8. aida

    aida Member

    Joined:
    Jul 11, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I also have this problem. I want to rebuild apache, but I keep getting the following error:

    Checking Update System........Your operating system's rpm update method (up2date) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed.
    Please correct the conflicts and try again!

    I already have glibc-2.3.4-2.19 installed (rpm -q told me so). OS is RHEL4
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Is up2date working? If not, then you need to get that working, or as Nick said, setup a yum mirror - either way you have to have a supported method of updating your OS.
     
Loading...

Share This Page