The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache on WHM broke my HTTPD

Discussion in 'EasyApache' started by demine0, Sep 16, 2009.

  1. demine0

    demine0 Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    I ran easyapache today to upgrade php to the latest version, and it broke my
    entire httpd installation. php pages won't display now. They only prompt
    browsers to download php files. I believe this may be caused by mod_php module not being loaded. I cannot find where cpanel keeps the configuration files for loaded modules though.

    You can view an example of what it is doing here:
    http://www.vaninollc.com/phpinfo.php
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    That PHP script loads as a web page for me just fine. Were you able to get this issue resolved since you made this post?
     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    This typically happens if the PHP build fails or you don't select a PHP configuration (final popup box at the end of EasyApache build). In that case, the web server does not know how to handle PHP scripts and will treat them as ordinary files to download.
     
Loading...

Share This Page