The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache - php 4.3.3 -> 4.3.4

Discussion in 'EasyApache' started by destr0yr, May 14, 2004.

  1. destr0yr

    destr0yr Well-Known Member

    Joined:
    May 4, 2004
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kelowna, BC.
    I'm having some issues, or just lack of understanding, with the /scripts/easyapache script. Running through the install, selecting php 4.3.5 w/the appropriate addons and compile options. However, after the compile is done I am still stuck with php 4.3.3. What have I missed, or what must I do to complete this process?
     
  2. tanq

    tanq Member

    Joined:
    Nov 11, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    I seem to have the same problem. I select php version 4.3.5 I´m have still the 4.3.3.

    Iäm trying to upgrade via WHM.
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Thread title: easyapache - php 4.3.3 -> 4.3.4

    If that is what you are trying to do there should be no problem. If trying to go from php 4.3.3 -> 4.3.5 there will be. You must upgrade to the next numerical version when using EasyApache or WHM.


    php 4.3.3 -> 4.3.4 and then php 4.3.4 -> 4.3.5 should solve the upgrade problem.
     
  4. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    I am having the same problem I actually posted a thread about it.. I should have searched first (live and learn). I tried going in order of PHP versions and that still didnt work.. It got me to 4.3.4 but stops from 4.3.4 and it wont install any modules... Im stuck with the same ones.
     
  5. tanq

    tanq Member

    Joined:
    Nov 11, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    same here, still no luck updating php.

    maybe it's because I have Zend Optimizer 2.5.1 installed?

    phpinfo shows 4.3.3 but in ssh "php -v" shows 4.2.2 - I don't get it...
     
  6. destr0yr

    destr0yr Well-Known Member

    Joined:
    May 4, 2004
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kelowna, BC.
    well, for whatever reason now, I can't even compile apache properly...

    help... using easyapache, any option, the following occurs. what can i do?

    Code:
    checking for PSPELL support... yes
    configure: error: Cannot find pspell
    make: *** No rule to make target `clean'.  Stop.
    make: *** No targets specified and no makefile found.  Stop.
    make: *** No rule to make target `install'.  Stop.
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    chattr: Inappropriate ioctl for device while reading flags on _vti_bin/fpexe
    ./build all
    ./build install
    Waiting for httpd to restart..............finished.
    
    31666
    
    httpd has failed, please contact the sysadmin.
    ./build install
    Waiting for httpd to restart..............finished.
    
    31723
    
    httpd has failed, please contact the sysadmin.
    
     
  7. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    Untrue, we went from 4.3.4 to 4.3.6 without problems. When upgrading make sure you uncheck the current version and check the new version you want. Most problems are when people forget to uncheck the current installed version first.
     
  8. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    Here is what we did..

    Opt 6 does not seem to work.. Period!

    After like 9 compiles we finally got 4.3.6 installed and that version only showed in SSH using php -v using php info in a script would show we had php 4.3.3. including MB showed us using 4.3.3.

    We compiled using opt 4 to get GD installed and it did compile it with that option and kept our existing settings and shot us back to 4.3.3 in both php info and php -v in ssh... GD is working as intended and PHPSUEXEC is installed.. I could really care less at this point if i dont have 4.3.5 or 4.3.6 I have a functional server atm. Would be nice if it didn't take 24hours to figure out I could have done so much more work... BTW we are also working with Zend if that makes any difference although I highly doubt that having Zend on the system would cause it not to update properly. I think it has something to do with buildapache..
    Note: The GD settings did take effect immediately I didn't have to compile it 19 times before it took.. IT seems like it liked using option 4 not 6 lol.
     
  9. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I haven't yet moved up to 4.3.6, but have found that moving up one version at a time, works just fine -- first time everytime. I use php as a module and Edge version, if that helps anyone.

    Last year I had read that EasyApache does not work well with PSPELL so I have never included it. I have noticed it here though:

    /usr/share/pspell

    and the following is in /usr/bin/

    aspell
    run-with-aspell
    spell
    ispell
    pine-spellcheck
    pspell-config


    I know 'aspell & ispell' are preferred for scripts like Horde, but what is the advantage of pspell?
     
  10. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    /scripts/easyapache option 6 is the leetest you'll ever get.

    just remember DONT select more than 1 php version and DONT select pspell.

    you'll be fine :)
     
  11. destr0yr

    destr0yr Well-Known Member

    Joined:
    May 4, 2004
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kelowna, BC.
    that one line saved my rear. Thank you sooo much.

    I option 6'd easyapache, w/out pspell and everything works now. Where do I make the paypal donation? ;)
     
  12. tanq

    tanq Member

    Joined:
    Nov 11, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    Yep, the "pspell" thing did the trick for me also.

    Thanks!
     
  13. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    Trying it without that pspell thing now.. Will post results.
     
  14. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    Easyapache still won't compile with option 6. Without PSpell.
     
Loading...

Share This Page