The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache - Php 5.4.4 not for Fcgi?

Discussion in 'EasyApache' started by Quemeros, Jul 13, 2012.

  1. Quemeros

    Quemeros Member

    Joined:
    Mar 4, 2012
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,
    today i try to upgrade (from EasyApache) my Php 5.3.x to 5.4.4, but i found the problem that Apache was don't using new build.
    Then i research and found that /usr/bin/php was the older version, but not the /usr/local/bin/php thats updated in 5.4.4.
    This is by using Fcgi, or Worker?

    There is a posibile to do both of things with Fcgi and Worker? At the moment, i preffer stay out of mod_ruid2 for mod_security problems... or how i can fix that problem?

    Thanks a lot,
    Facundo
     
  2. Quemeros

    Quemeros Member

    Joined:
    Mar 4, 2012
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Nobody knows? :/
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Facundo,

    We have internal case 60279 on this issue. Right now, if you select an MPM other than prefork, you won't build the binary for /usr/bin/php on the second pass for CGI (it sets it to --disable-cgi). Right now, that hasn't been fixed, so you might try selecting prefork until this has been resolved.

    Otherwise, the machine could be compiled with PHP 5.3 until the case has been released. You'll find it posted at Change Logs for the EasyApache area once the case has been pushed into a production EasyApache build.

    Thanks!
     
Loading...

Share This Page