Oct 26, 2012
7
0
1
cPanel Access Level
Root Administrator
Hi there
When trying to add PDO support through EasyApache, the rebuild fails. Even trying a 'Basic' build fails.
Below is the log. I notice this line first:
Error: Protected multilib versions: libgcc-4.4.6-4.el6.i686 != libgcc-4.4.6-3.el6.x86_64
How do I resolve this?
There are also other errors after this - Are they the result of the above error, and should resolve themselves once I fix that?
Thanks for your time,
Karl

Here is the log:
Your OS software management system does not appear to be functioning correctly.

Please visit EaError < AllDocumentation < TWiki for help with this error.

EaError < AllDocumentation < TWiki


If the browser window is closed or stopped the build will continue in the background.
The build output should start shortly...

Distilled successfully
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1351223152' !!
!!
Output from '/bin/sh -c "ulimit -a"':
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 15836
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) 1048576
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 10240
cpu time (seconds, -t) unlimited
max user processes (-u) 1024
virtual memory (kbytes, -v) 1048576
file locks (-x) unlimited
!!
!! Creating backup of working apache in '/usr/local/apache.backup'. !!
!! Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!

!! Backup of working apache complete. !!
Checking that all tarballs are present and up to date.
!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/Apache/2_2.pm.tar.gz' !!

!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/3_18.pm.tar.gz' !!

!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/3_18.pm.patch.tar.gz' !!

!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/IonCubeLoader.pm.tar.gz.linux-generic-64' !!

Checking that all packages are present and up to date.
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
* cloudlinux-x86_64-server-6: cl-mirror.syd.ventraip.net.au
Setting up Install Process
Package gettext-0.17-16.el6.x86_64 already installed and latest version
No package automake19 available.
Package 2:libpng-devel-1.2.49-1.el6_2.x86_64 already installed and latest version
No package libpng-dev available.
Package zlib-devel-1.2.3-27.el6.x86_64 already installed and latest version
No package autoconf261 available.
Package libidn-devel-1.18-2.el6.x86_64 already installed and latest version
No package gmake available.
Package libidn-1.18-2.el6.x86_64 already installed and latest version
Package libXpm-3.5.8-2.el6.x86_64 already installed and latest version
Package automake-1.11.1-1.2.el6.noarch already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
No package libltdl3-devel available.
No package libltdl available.
No package libopenssl0.9.7-static-devel available.
Package libtool-ltdl-devel-2.2.6-15.5.el6.x86_64 already installed and latest version
Package libXpm-devel-3.5.8-2.el6.x86_64 already installed and latest version
No package libXpm-dev available.
Package lsof-4.82-4.el6.x86_64 already installed and latest version
No package krb5-dev available.
Package flex-2.5.35-8.el6.x86_64 already installed and latest version
No package glibc-dev available.
No package expat-dev available.
No package libstdc++-devel.x64_64 available.
No package xorg-x11-devel available.
Package libtool-ltdl-2.2.6-15.5.el6.x86_64 already installed and latest version
No package libssl-dev available.
Package bzip2-devel-1.0.5-7.el6_0.x86_64 already installed and latest version
Package pam-devel-1.1.1-10.el6_2.1.x86_64 already installed and latest version
No package libopenssl0-devel available.
No package zlib1-devel available.
No package libopenssl0-dev available.
Package zlib-1.2.3-27.el6.x86_64 already installed and latest version
Package bison-2.4.1-5.el6.x86_64 already installed and latest version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest version
No package libtool-libltdl-devel available.
Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
No package openssl-dev available.
No package libopenssl0 available.
Package bzip2-libs-1.0.5-7.el6_0.x86_64 already installed and latest version
No package libz-devel available.
No package libjpeg-dev available.
No package pam-dev available.
No package libltdl-devel available.
No package libopenssl0.9.7-devel available.
No package ca_root_nss available.
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
No package libstdc++-dev.x86_64 available.
Package libX11-devel-1.3-2.el6.x86_64 already installed and latest version
No package xorg-x11-dev available.
No package ssl-dev available.
No package lex available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package coreutils.x86_64 0:8.4-16.el6 will be updated
--> Processing Dependency: coreutils = 8.4-16.el6 for package: coreutils-libs-8.4-16.el6.x86_64
---> Package coreutils.x86_64 0:8.4-19.el6 will be an update
---> Package cpp.x86_64 0:4.4.6-3.el6 will be updated
---> Package cpp.x86_64 0:4.4.6-4.el6 will be an update
---> Package e2fsprogs-devel.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs-devel.x86_64 0:1.41.12-12.el6 will be an update
--> Processing Dependency: libcom_err-devel = 1.41.12-12.el6 for package: e2fsprogs-devel-1.41.12-12.el6.x86_64
--> Processing Dependency: e2fsprogs-libs = 1.41.12-12.el6 for package: e2fsprogs-devel-1.41.12-12.el6.x86_64
---> Package expat.x86_64 0:2.0.1-9.1.el6 will be updated
---> Package expat.x86_64 0:2.0.1-11.el6_2 will be an update
---> Package expat-devel.x86_64 0:2.0.1-9.1.el6 will be updated
---> Package expat-devel.x86_64 0:2.0.1-11.el6_2 will be an update
---> Package gcc.x86_64 0:4.4.6-3.el6 will be updated
---> Package gcc.x86_64 0:4.4.6-4.el6 will be an update
--> Processing Dependency: libgomp = 4.4.6-4.el6 for package: gcc-4.4.6-4.el6.x86_64
---> Package gcc-c++.x86_64 0:4.4.6-3.el6 will be updated
---> Package gcc-c++.x86_64 0:4.4.6-4.el6 will be an update
---> Package gd.x86_64 0:2.0.35-10.el6 will be updated
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-devel-2.0.35-10.el6.x86_64
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-progs-2.0.35-10.el6.x86_64
---> Package gd.x86_64 0:2.0.35-11.el6 will be an update
---> Package glibc.i686 0:2.12-1.47.el6_2.9 will be updated
---> Package glibc.i686 0:2.12-1.80.el6_3.5 will be an update
--> Processing Dependency: glibc-common = 2.12-1.80.el6_3.5 for package: glibc-2.12-1.80.el6_3.5.i686
---> Package glibc-devel.i686 0:2.12-1.47.el6_2.9 will be updated
--> Processing Dependency: glibc-devel = 2.12-1.47.el6_2.9 for package: glibc-static-2.12-1.47.el6_2.9.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.47.el6_2.9 will be updated
---> Package glibc-devel.i686 0:2.12-1.80.el6_3.5 will be an update
--> Processing Dependency: glibc-headers = 2.12-1.80.el6_3.5 for package: glibc-devel-2.12-1.80.el6_3.5.i686
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package krb5-devel.x86_64 0:1.9-22.el6_2.1 will be updated
---> Package krb5-devel.x86_64 0:1.9-33.el6_3.3 will be an update
--> Processing Dependency: krb5-libs = 1.9-33.el6_3.3 for package: krb5-devel-1.9-33.el6_3.3.x86_64
---> Package libgcc.i686 0:4.4.6-3.el6 will be updated
---> Package libgcc.i686 0:4.4.6-4.el6 will be an update
---> Package liblve-devel.x86_64 0:1.1-0.20.el6.cloudlinux will be updated
---> Package liblve-devel.x86_64 0:1.1-0.37.el6.cloudlinux will be an update
--> Processing Dependency: liblve = 1.1-0.37.el6.cloudlinux for package: liblve-devel-1.1-0.37.el6.cloudlinux.x86_64
---> Package libstdc++.x86_64 0:4.4.6-3.el6 will be updated
---> Package libstdc++.x86_64 0:4.4.6-4.el6 will be an update
---> Package libstdc++-devel.x86_64 0:4.4.6-3.el6 will be updated
---> Package libstdc++-devel.x86_64 0:4.4.6-4.el6 will be an update
---> Package openssl.x86_64 0:1.0.0-20.el6_2.4 will be updated
---> Package openssl.x86_64 0:1.0.0-25.el6_3.1 will be an update
---> Package openssl-devel.x86_64 0:1.0.0-20.el6_2.4 will be updated
---> Package openssl-devel.x86_64 0:1.0.0-25.el6_3.1 will be an update
---> Package sed.x86_64 0:4.2.1-7.el6 will be updated
---> Package sed.x86_64 0:4.2.1-10.el6 will be an update
--> Running transaction check
---> Package coreutils-libs.x86_64 0:8.4-16.el6 will be updated
---> Package coreutils-libs.x86_64 0:8.4-19.el6 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-11.el6 will be updated
--> Processing Dependency: e2fsprogs-libs = 1.41.12-11.el6 for package: e2fsprogs-1.41.12-11.el6.x86_64
---> Package e2fsprogs-libs.x86_64 0:1.41.12-12.el6 will be an update
--> Processing Dependency: libcom_err = 1.41.12-12.el6 for package: e2fsprogs-libs-1.41.12-12.el6.x86_64
---> Package gd-devel.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-devel.x86_64 0:2.0.35-11.el6 will be an update
---> Package gd-progs.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-progs.x86_64 0:2.0.35-11.el6 will be an update
---> Package glibc-common.x86_64 0:2.12-1.47.el6_2.9 will be updated
--> Processing Dependency: glibc-common = 2.12-1.47.el6_2.9 for package: glibc-2.12-1.47.el6_2.9.x86_64
---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.47.el6_2.9 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-static.x86_64 0:2.12-1.47.el6_2.9 will be updated
---> Package glibc-static.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package krb5-libs.x86_64 0:1.9-22.el6_2.1 will be updated
---> Package krb5-libs.x86_64 0:1.9-33.el6_3.3 will be an update
---> Package libcom_err-devel.x86_64 0:1.41.12-11.el6 will be updated
---> Package libcom_err-devel.x86_64 0:1.41.12-12.el6 will be an update
---> Package libgomp.x86_64 0:4.4.6-3.el6 will be updated
---> Package libgomp.x86_64 0:4.4.6-4.el6 will be an update
---> Package liblve.x86_64 0:1.1-0.20.el6.cloudlinux will be updated
---> Package liblve.x86_64 0:1.1-0.37.el6.cloudlinux will be an update
--> Processing Dependency: lve = 1.1-0.37.el6.cloudlinux for package: liblve-1.1-0.37.el6.cloudlinux.x86_64
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.41.12-12.el6 will be an update
--> Processing Dependency: libss = 1.41.12-12.el6 for package: e2fsprogs-1.41.12-12.el6.x86_64
---> Package glibc.x86_64 0:2.12-1.47.el6_2.9 will be updated
---> Package glibc.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package libcom_err.x86_64 0:1.41.12-11.el6 will be updated
---> Package libcom_err.x86_64 0:1.41.12-12.el6 will be an update
---> Package lve.x86_64 0:1.1-0.20.el6.cloudlinux will be updated
---> Package lve.x86_64 0:1.1-0.37.el6.cloudlinux will be an update
--> Running transaction check
---> Package libss.x86_64 0:1.41.12-11.el6 will be updated
---> Package libss.x86_64 0:1.41.12-12.el6 will be an update
--> Finished Dependency Resolution
Error: Protected multilib versions: libgcc-4.4.6-4.el6.i686 != libgcc-4.4.6-3.el6.x86_64
You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
exim-4.80-0.x86_64 has missing requires of perl(SafeFile)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
!! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!

!! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!

!! Could not ensure pkglist 'gettext, automake19, libstdc++.x86_64, libpng-devel, openssl, libpng-dev, zlib-devel, glibc-devel.i686, autoconf261, libidn-devel, gmake, libidn, libXpm, openssl-devel, automake, coreutils, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, libtool-ltdl-devel, sed, libXpm-devel, libXpm-dev, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, libstdc++-devel.x64_64, xorg-x11-devel, glibc.i686, libtool-ltdl, libssl-dev, bzip2-devel, pam-devel, libopenssl0-devel, zlib1-devel, liblve-devel, expat-devel, libopenssl0-dev, gcc-c++, glibc-devel, expat, zlib, bison, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, libgcc.i686, bzip2-libs, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, e2fsprogs-devel, ca_root_nss, make, libstdc++-dev.x86_64, libX11-devel, libstdc++-devel.x86_64, gd, cpp, xorg-x11-dev, gcc, ssl-dev, lex, autoconf' !!
!! The server's system package manager, 'YUM', failed. !!

!!
This is the command that failed: yum --exclude=kernel* -y install gettext automake19 libstdc++.x86_64 libpng-devel openssl libpng-dev zlib-devel glibc-devel.i686 autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel libtool-ltdl-devel sed libXpm-devel libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel glibc.i686 libtool-ltdl libssl-dev bzip2-devel pam-devel libopenssl0-devel zlib1-devel liblve-devel expat-devel libopenssl0-dev gcc-c++ glibc-devel expat zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libgcc.i686 bzip2-libs libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf !!

!!
Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at EaError < AllDocumentation < TWiki 3) Resolve the YUM problem manually 4) Re-run EasyApache !!

!! Please visit EaError < AllDocumentation < TWiki for help with this error. !!

!! Restoring original working apache !!

!! Executing '/scripts/initsslhttpd' !!
!! Restarting 'httpd' ... !!
!! 'httpd' restart complete. !!
Building global cache for cpanel...Done
!! Executing '/scripts/initfpsuexec' !!
!! Executing '/scripts/initsslhttpd' !!
!! Executing '/scripts/update_apachectl' !!
Compiling report...
Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
!! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '9194751' !!

Report processed.
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1351223152' !!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

The portion with the failing error onward would have been better to provide. I had to change to quote so the output was even readable.

As for the specific error:

Error: Protected multilib versions: libgcc-4.4.6-4.el6.i686 != libgcc-4.4.6-3.el6.x86_64
Please try running the following:

Code:
yum update gcc
If that does not work, please submit a ticket via WHM > Support Center > Contact cPanel or using the link in my signature.

Thanks!
 
Oct 26, 2012
7
0
1
cPanel Access Level
Root Administrator
Thanks, Tristan
I'm still new to this and wasn't sure what might be relevant, so posted the lot.
Should I run that yum update and then re-run EasyApache with my required settings?
Thanks,
Karl
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Karl,

No worries on the post, just letting you know for the future.

As for how to proceed, you would want to run the yum command for updating gcc, then correct that you'd re-run EasyApache again.

Thanks!