The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache running failed Yum command...

Discussion in 'EasyApache' started by itzhero, Dec 16, 2010.

  1. itzhero

    itzhero Active Member

    Joined:
    Nov 16, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Hello all,

    When running EasyApache, it fails on running the following command:
    When I run via ssh as root, three errors are returned:
    Running 'yum install libsepol' [libselinux, and e2fsporgs-lib] fails.

    Any ideas on a fix?
     
  2. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    What is the output for yum installation of these packages?
     
  3. itzhero

    itzhero Active Member

    Joined:
    Nov 16, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    # yum install libsepol
    Code:
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
     * base: mirror.san.fastserv.com
     * updates: mirrors.easynews.com
     * addons: mirror.5ninesolutions.com
     * extras: mirror.san.fastserv.com
    base                      100% |=========================| 2.1 kB    00:00     
    updates                   100% |=========================| 1.9 kB    00:00     
    addons                    100% |=========================|  951 B    00:00     
    extras                    100% |=========================| 2.1 kB    00:00     
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    ---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
    ---> Package libsepol.x86_64 0:1.15.2-3.el5 set to be updated
    --> Processing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) for package: libsepol
    --> Processing Dependency: libc.so.6()(64bit) for package: libsepol
    --> Processing Dependency: libc.so.6(GLIBC_2.3.4)(64bit) for package: libsepol
    --> Processing Dependency: libc.so.6(GLIBC_2.4)(64bit) for package: libsepol
    --> Processing Dependency: libc.so.6(GLIBC_2.3)(64bit) for package: libsepol
    --> Running transaction check
    ---> Package glibc.x86_64 0:2.5-49.el5_5.7 set to be updated
    --> Processing Dependency: glibc-common = 2.5-49.el5_5.7 for package: glibc
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    ---> Package glibc.i686 0:2.5-49.el5_5.7 set to be updated
    --> Running transaction check
    ---> Package glibc-common.x86_64 0:2.5-49.el5_5.7 set to be updated
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    --> Finished Dependency Resolution
    Error: Missing Dependency: libsepol = 1.15.2-1.el5 is needed by package libsepol-devel
    # yum install libselinux
    Code:
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
     * base: mirror.san.fastserv.com
     * updates: mirrors.easynews.com
     * addons: mirror.5ninesolutions.com
     * extras: mirror.san.fastserv.com
    base                      100% |=========================| 2.1 kB    00:00     
    updates                   100% |=========================| 1.9 kB    00:00     
    addons                    100% |=========================|  951 B    00:00     
    extras                    100% |=========================| 2.1 kB    00:00     
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    ---> Package libselinux.i386 0:1.33.4-5.5.el5 set to be updated
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-python
    ---> Package libselinux.x86_64 0:1.33.4-5.5.el5 set to be updated
    --> Processing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) for package: libselinux
    --> Processing Dependency: libdl.so.2()(64bit) for package: libselinux
    --> Processing Dependency: libc.so.6()(64bit) for package: libselinux
    --> Processing Dependency: ld-linux-x86-64.so.2()(64bit) for package: libselinux
    --> Processing Dependency: libc.so.6(GLIBC_2.3)(64bit) for package: libselinux
    --> Processing Dependency: libc.so.6(GLIBC_2.4)(64bit) for package: libselinux
    --> Processing Dependency: libc.so.6(GLIBC_2.3.4)(64bit) for package: libselinux
    --> Processing Dependency: ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) for package: libselinux
    --> Processing Dependency: libsepol.so.1()(64bit) for package: libselinux
    --> Running transaction check
    ---> Package glibc.x86_64 0:2.5-49.el5_5.7 set to be updated
    --> Processing Dependency: glibc-common = 2.5-49.el5_5.7 for package: glibc
    ---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
    ---> Package libsepol.x86_64 0:1.15.2-3.el5 set to be updated
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    ---> Package libselinux-python.x86_64 0:1.33.4-5.5.el5 set to be updated
    ---> Package glibc.i686 0:2.5-49.el5_5.7 set to be updated
    --> Running transaction check
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
    ---> Package glibc-common.x86_64 0:2.5-49.el5_5.7 set to be updated
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    --> Finished Dependency Resolution
    Error: Missing Dependency: libsepol = 1.15.2-1.el5 is needed by package libsepol-devel
    Error: Missing Dependency: libselinux = 1.33.4-5.el5 is needed by package libselinux-devel

    # yum install e2fsprogs-libs
    Code:
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
     * base: mirror.san.fastserv.com
     * updates: mirrors.easynews.com
     * addons: mirror.5ninesolutions.com
     * extras: mirror.san.fastserv.com
    base                      100% |=========================| 2.1 kB    00:00     
    updates                   100% |=========================| 1.9 kB    00:00     
    addons                    100% |=========================|  951 B    00:00     
    extras                    100% |=========================| 2.1 kB    00:00     
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Parsing package install arguments
    Package e2fsprogs-libs - 1.39-23.el5.i386 is already installed.
    Resolving Dependencies
    --> Running transaction check
    ---> Package e2fsprogs-libs.i386 0:1.39-23.el5_5.1 set to be updated
    ---> Package e2fsprogs-libs.x86_64 0:1.39-23.el5_5.1 set to be updated
    --> Processing Dependency: libdevmapper.so.1.02()(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libdl.so.2()(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libc.so.6(GLIBC_2.3.4)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libc.so.6()(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: ld-linux-x86-64.so.2()(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libc.so.6(GLIBC_2.3)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libdevmapper.so.1.02(Base)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libc.so.6(GLIBC_2.4)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: e2fsprogs-libs
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel
    --> Running transaction check
    ---> Package glibc.x86_64 0:2.5-49.el5_5.7 set to be updated
    --> Processing Dependency: glibc-common = 2.5-49.el5_5.7 for package: glibc
    ---> Package device-mapper.i386 0:1.02.39-1.el5_5.2 set to be updated
    ---> Package device-mapper.x86_64 0:1.02.39-1.el5_5.2 set to be updated
    --> Processing Dependency: libsepol.so.1()(64bit) for package: device-mapper
    --> Processing Dependency: libselinux.so.1()(64bit) for package: device-mapper
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel
    ---> Package glibc.i686 0:2.5-49.el5_5.7 set to be updated
    --> Running transaction check
    ---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
    ---> Package libselinux.x86_64 0:1.33.4-5.5.el5 set to be updated
    ---> Package libselinux.i386 0:1.33.4-5.5.el5 set to be updated
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-python
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    ---> Package glibc-common.x86_64 0:2.5-49.el5_5.7 set to be updated
    ---> Package libsepol.x86_64 0:1.15.2-3.el5 set to be updated
    --> Running transaction check
    --> Processing Dependency: libselinux = 1.33.4-5.el5 for package: libselinux-devel
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs
    --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel
    --> Processing Dependency: libsepol = 1.15.2-1.el5 for package: libsepol-devel
    ---> Package libselinux-python.x86_64 0:1.33.4-5.5.el5 set to be updated
    --> Finished Dependency Resolution
    Error: Missing Dependency: libsepol = 1.15.2-1.el5 is needed by package libsepol-devel
    Error: Missing Dependency: libselinux = 1.33.4-5.el5 is needed by package libselinux-devel
    Error: Missing Dependency: e2fsprogs-libs = 1.39-23.el5 is needed by package e2fsprogs
    Error: Missing Dependency: e2fsprogs-libs = 1.39-23.el5 is needed by package e2fsprogs-devel
     
  4. RACKSET

    RACKSET Active Member

    Joined:
    Apr 28, 2006
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    localhost
    Sorry for bump this up, but the answer for Googlers:

    see /etc/yum.conf

    exclude=apache* bind-chroot courier* dev* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail* udev* wget*

    And the break is caused by the package device-mapper (which provides libdevmapper.so.1.02) being excluded.
    Those excludes need examining carefully, they are what's breaking the update, not to mention any security issues...

    Cheers,
     
  5. alphawolf50

    alphawolf50 Well-Known Member

    Joined:
    Apr 28, 2011
    Messages:
    186
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Where did you get your excludes list? It does not match the instructions here, which say:
    Code:
    Exclude= apache* bind-chroot courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* spamassassin* squirrelmail*
    Specifically, ruby*, udev*, and wget* are not in the instructions.
     
Loading...

Share This Page