The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easyapache runs but doesn't update ?

Discussion in 'EasyApache' started by nyjimbo, Jun 5, 2006.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    I finally decided to give the Easyapache update to get the frontpage fix and to go from Apache 1.3.34 to 1.3.36 (this is on a Freebsd system).

    Ran easyapache, changed NOTHING, just checked to be sure everything was ok. Stayed with PHP4.4.2, etc.

    Everything seemed to run perfectly, took about 15-20 minutes and then it brought apache back up.

    When I went to check I see this :

    "Apache/1.3.34 (Unix) mod_auth_passthrough/1.8 mod_bwprotect/0.2 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.2 FrontPage/5.0.2.2635 mod_ssl/2.8.25 OpenSSL/0.9.6g "

    which means it did NOT update anything. I didnt see any errors and I DID see it untarring Apache 1.3.36 so something went wrong, but I don't know what.

    Is there a Apache compile log somewhere on the system?. I tried to do it again and the same exact thing happened.
     
  2. Somethingblue

    Somethingblue Member

    Joined:
    Sep 28, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I had this same problem today on many of our servers. Regardless of the options checked with /scripts/easyapache PHP 4.4.2 would be compiled, all module selections would be ignored, etc...

    But no errors.

    To fix, I ran:

    /scripts/upcp --force

    from shell.

    Once cPanel was done updating, I ran easyapache again.

    Problem Solved.
     
    #2 Somethingblue, Jun 6, 2006
    Last edited: Jun 7, 2006
  3. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Nope, doesn't solve my problem. I just wish I knew if there were any logs from the apache compile I could look at.
     
  4. dwolf77

    dwolf77 Member

    Joined:
    Jun 6, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Atlanta, GA
    I am having a simlar issue I tried the above suggestions and I had no luck.

    I have submittted a support ticket to cPanel I am out of ideas. Any one help....

    Specifically I am trying to add pdf support to my Apache/PHP settings. The strange part is that I have compiled with easyApache three times and seem to get no errors however my compile date when doing a phpinfo script never changes.

    If it helps any I am running:
    WHM 10.8.0 cPanel 10.8.2-C118
    CentOS 4.3 x86_64 - WHM X v3.1.0

    This is the header section of the phpinfo.
    PHP Version 4.4.2
    Build Date Jun 2 2006 18:03:13
    Configure Command './configure' '--enable-pic' '--with-libdir=lib64' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--with-zlib'
     
    #4 dwolf77, Jun 8, 2006
    Last edited: Jun 8, 2006
  5. ZeusChicago

    ZeusChicago Active Member

    Joined:
    Oct 9, 2005
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
  6. dwolf77

    dwolf77 Member

    Joined:
    Jun 6, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Atlanta, GA
    Still no luck I tried with the upcp --force and a good many items did get updated, then I did easyApache option 7 verifying that PDF was a selected option and still had the same results.

    Any other ideas?

    Did I mention this is a new install that was created on last Friday?
     
  7. dwolf77

    dwolf77 Member

    Joined:
    Jun 6, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Atlanta, GA
    Help do I install PDF for php

    So I got a response from cPanel's support system today does any one know how to do what he is telling me?

    Also do you know if my customers code will work when all is said and done?


    ===============================================================
    This is cpanels response:
    The pdf module is no longer bundled with PHP. You'll need to install it via
    pecl or pear.
    ===============================================================

    I am a newb to running a cPanel server, but have been a reseller for a few years, and I do not want to break cPanel by doing something wrong.

    Thanks...
     
  8. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    run: pecl install pdflib
    from the shell (if your tmp dir is not noexec)
    if your tmp dir is noexec you will have to manually download the tar.gz from pecl.pear.net and use phpize to configure it
     
  9. dwolf77

    dwolf77 Member

    Joined:
    Jun 6, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Atlanta, GA
    Thanks for the help, I had to do that and I had to install the pdf-lite library and things straightened up.

    Thanks Again.
     
Loading...

Share This Page