OscarWilde

Registered
May 5, 2011
2
0
51
Hello,

after 3 days of trying, I finally give up. Is there someone who can help me with this problem or I should open a ticket?

This is what I see...

Code:
+--------------------------------------------------------------------+
|                        *** ATTENTION ***                           |
|                                                                    |
| You've configured multiple SAPIs to be build. You can build only   |
| one SAPI module and CLI binary at the same time.                   |
+--------------------------------------------------------------------+
!! './configure --disable-cgi --disable-pdo --enable-bcmath --enable-calendar --enable-exif --enable-fpm --enable-ftp --enable-intl --enable-libxml --enable-magic-quotes --enable-mbstring --enable-soap --enable-sockets --enable-zip --prefix=/usr/local --with-apxs2=/usr/local/apache/bin/apxs --with-bz2 --with-curl=/opt/curlssl/ --with-curlwrappers --with-gettext --with-icu-dir=/usr --with-imap=/opt/php_with_imap_client/ --with-imap-ssl=/usr --with-kerberos --with-libdir=lib64 --with-libxml-dir=/opt/xml2 --with-libxml-dir=/opt/xml2/ --with-mcrypt=/opt/libmcrypt/ --with-mysql --with-openssl=/usr --with-openssl-dir=/usr --with-pcre-regex=/opt/pcre --with-pic --with-tidy=/opt/tidy/ --with-zlib --with-zlib-dir=/usr' failed with exit code '256' !!
View attachment build.1312444409.txt
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
41
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
The issue is that you've placed --enable-fpm into some file you have in /var/cpanel/easy/apache/rawopts and this is causing the build to fail. Remove that flag option and it should then build properly.